HDU3549(Flow Problem)

Flow Problem

Problem Description

Network flow is a well-known difficult problem for ACMers. Given a graph, your task is to find out the maximum flow for the weighted directed graph.

Input

The first line of input contains an integer T, denoting the number of test cases.
For each test case, the first line contains two integers N and M, denoting the number of vertexes and edges in the graph. (2 <= N <= 15, 0 <= M <= 1000)
Next M lines, each line contains three integers X, Y and C, there is an edge from X to Y and the capacity of it is C. (1 <= X, Y <= N, 1 <= C <= 1000)

Output

For each test cases, you should output the maximum flow from source 1 to sink N.

Sample Input

2
3 2
1 2 1
2 3 1
3 3
1 2 1
2 3 1
1 3 1

Sample Output

Case 1: 1
Case 2: 2

思路

最大流模板题,三大算法都能过。好久没用链式前向星写题了,贴个模板纪念一下。

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
#include <queue>
#include <cmath>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
struct edge{
	int to;
	int next;
	int w;
}e[maxn<<1];
int head[20];
int dep[20];
int tot;
void addedge(int x,int y,int z)
{
	e[tot].to = y;
	e[tot].w = z;
	e[tot].next = head[x];
	head[x] = tot++;
}
int bfs(int s,int t)
{
	memset(dep,0,sizeof(dep));
	queue<int>q;
	q.push(s);dep[s] = 1;
	while(!q.empty()){
		int x = q.front();
		q.pop();
		for(int i = head[x];~i;i = e[i].next){
			if(e[i].w && !dep[e[i].to]){
				dep[e[i].to] = dep[x] + 1;
				q.push(e[i].to);
			}
		}
	}
	return dep[t];
}
int dfs(int s,int flow,int t)
{
	if(s == t)		return flow;
	int sum = 0;
	for(int i = head[s];~i;i = e[i].next){
		if(e[i].w && dep[e[i].to] == dep[s]+1){
			int k = dfs(e[i].to,min(flow-sum,e[i].w),t);
			if(k){
				e[i].w -= k;
				e[i^1].w += k;
				sum += k;
				if(sum == flow)		break;
			}
		}
	}
	if(!sum)		dep[s] = -1;		//炸点
	return sum;
}
int Dinic(int s,int t)
{
	int sum = 0;
	while(bfs(s,t)){
		sum += dfs(s,inf,t);
	}
	return sum;
}
int main()
{
	int t,n,m;
	scanf("%d",&t);
	for(int k = 1;k <= t;k++){
		tot = 0;
		memset(head,-1,sizeof(head));
		scanf("%d%d",&n,&m);
		for(int i = 0;i < m;i++){
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			addedge(x,y,z);	addedge(y,x,0);	
		}
		int sum = Dinic(1,n);
		printf("Case %d: %d\n",k,sum);
	}
	return 0;
} 

愿你走出半生,归来仍是少年~

weixin073智慧旅游平台开发微信小程序+ssm后端毕业源码案例设计 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 4、下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值