PAT (Advanced Level) Practice 1046 Shortest Distance (20 分)

19 篇文章 0 订阅
17 篇文章 0 订阅
该博客主要讨论如何解决给定一个包含N个出口的高速公路简单环形路线,求任意两个出口之间的最短距离的问题。输入包括出口间的距离数组和查询对数,输出为每对出口之间的最短距离。代码中利用前缀和技巧求解,实现了在限定时间内找出最短路径的方法。
摘要由CSDN通过智能技术生成

题目

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 1 0 5 10^5 105​​ ]), followed by N integer distances D 1 D_1 D1, D 2 D_2 D2,···, D n D_n Dn ​​ , where D i D_i Di​​ is the distance between the i-th and the (i+1)-st exits, and D n D_n Dn is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (≤ 1 0 4 10^4 104​​ ), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 1 0 7 10^7 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10
7

代码

#include<iostream>
using namespace std;
int main()
{
	int n;
	scanf("%d",&n);
	int a[n+1];
	int lj[n+1] = {0};
	int sum = 0;
	for(int i = 1;i <= n;i++)
	{
		scanf("%d",&a[i]);
		lj[i] = a[i]+lj[i-1];
		sum = sum + a[i];
	}
	int m;
	scanf("%d",&m);
	for(int i = 1;i <= m;i++)
	{
		int d1,d2;
		scanf("%d %d",&d1,&d2);
		if(d1 > d2)
			swap(d1,d2);
		int a = lj[d2-1]-lj[d1-1];
		int b = sum - a;
		printf("%d\n",min(a,b));
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

weixin_43820008

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值