【北大poj】1002 487-3279

北大poj 1002 487-3279

Description

Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP. Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino’s by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could order your pizza from Pizza Hut by calling their ``three tens’’ number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2
D, E, and F map to 3
G, H, and I map to 4
J, K, and L map to 5
M, N, and O map to 6
P, R, and S map to 7
T, U, and V map to 8
W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input

The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output

Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input

12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output

310-1010 2
487-3279 4
888-4567 3

思路:考察字符串的处理吧。

首先要对格式不一的电话号码统一格式:遍历输入的号码,将字母统一改为数字,忽略所有下划线,还要在第三位数字后面添加上‘-’

然后将统一格式的字符一一存到新建的二维数组里。

观察样例输出的顺序,发现电话号码是从小到大排列的。所以想到给电话号码排序。排序后相等的号码必然连续,所以只需要统计有多少连续再输出之即可。

代码实现:(自己运行没错,没有AC不知为何)


#include<iostream>
#include<stdlib.h>
#define MAXSIZE 100

using namespace std;

int comp(const void*a,const void*b)
{
    char *sa = (char *)a;
    char *sb = (char *)b;
    return strcmp(sa,sb);
}

int main()
{
    char m[]="22233344455566677778889999";
    int n; //输入电话号码个数
    int k=0;
    
    cin >> n;
    
    char r[MAXSIZE];
    char s[n][9];

    for(int i=0;i<n;i++)
    {
        cin >> r;
        k = 0;
        //将输入的号码标准化
        for(int j=0;k<8;j++)
        {
            if(k==3)
                s[i][k++]='-';//在第三位插入连字符
            if(r[j]>='A'&&r[j]<='Z')
                s[i][k] = m[r[j]-'A'];
            if(r[j] == '-')
                continue;
            if(r[j]>='0'&&r[j]<='9')
                s[i][k] = r[j];
            k = k+1;//s的长度+1
        }
        s[i][8] = '\0'; //添加结尾标志符!!!很重要
    }

    //比较统计相同号码
    qsort(s,n,9,comp);
    int count = 1;
    int flag = 0;
    for(int i = 0;i<n;i++)
    {
        if(strcmp(s[i], s[i-1]) == 0){
            flag = 1;
            count++;
        }
        else{//没有重复
            if(count > 1){
                cout << s[i-1] << ' ' << count << endl;
            }
            count = 1;
        }
    }
    if(count > 1){//查看最后一条记录是否有重复
        cout << s[n-1] << ' ' << count << endl;
    }
    if (flag == 0)
        cout << "No duplicates."<<endl;

    return 0;
}

参考链接:此博客用C语言实现

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值