POJ 2782 Bin Packing

题面链接:点击跳转

Description
A set of n 1-dimensional items have to be packed in identical bins. All bins have exactly the same length l and each item i has length li<=l . We look for a minimal number of bins q such that

  • each bin contains at most 2 items,
  • each item is packed in one of the q bins,
  • the sum of the lengths of the items packed in a bin does not exceed l .

You are requested, given the integer values n , l , l1 , …, ln , to compute the optimal number of bins q .

Input
The first line of the input contains the number of items n (1<=n<=105) . The second line contains one integer that corresponds to the bin length l<=10000 . We then have n lines containing one integer value that represents the length of the items.

Output
Your program has to write the minimal number of bins required to pack all items.

Sample Input
10
80
70
15
30
35
10
80
20
35
10
30

Sample Output
6

Hint
The sample instance and an optimal solution is shown in the figure below. Items are numbered from 1 to 10 according to the input order.
在这里插入图片描述
解题思路:
把物品排序一遍,因为要一个箱子固定了最多只能装2个物品,那么如果要使两个物品的总和尽可能小,那么需要贪心的每次取最大和最小的合起来,看看能不能装的下,装得下就装减去,否则装大的进去,每次计数,最后输出次数即可.

代码如下:

#include <iostream>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long ll;
int c[(int)1e5+5];
int main(){
    ios::sync_with_stdio(false);
    int n,len;
    while(cin>>n>>len){
        for(int i=0;i<n;i++){
            cin>>c[i];
        }
        sort(c,c+n);
        int sum=0;
        int l=0,r=n-1;
        while(l<=r){
            if(l==r){//只有一个物品了直接退出即可,避免出错
                sum++;
                break;
            }
            if(c[l]+c[r]<=len){
                sum++;
                l++;
                r--;
            }else{
                sum++;
                r--;
            }
        }
        cout<<sum<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值