Hdu 5443 The Water Problem

题面链接:添加链接描述
Problem Description
In Land waterless, water is a very limited resource. People always fight for the biggest source of water. Given a sequence of water sources with a1,a2,a3,…,an representing the size of the water source. Given a set of queries each containing 2 integers l and r, please find out the biggest water source between al and ar.

Input
First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,…,an, and each integer is in {1,…,106}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.

Output
For each query, output an integer representing the size of the biggest water source.

Sample Input
3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3

Sample Output
100
2
3
4
4
5
1
999999
999999
1

解题思路
区间最值问题,用rmq算法,树状数组等可以轻松解决,我用了树状数组解决该问题.

代码如下:

#include <bits/stdc++.h>

using namespace std;
typedef long long ll;
const int N = 1e5+5;
int a[N],c[N],n;
int lowbit(int r){
    return r&(-r);
}
void updata(int i,int res){//单点更新,虽然这题没用到
    a[i]=res;
    while(i<=n){
        c[i]=res;
        for(int j=1;j<lowbit(i);j<<=1){
            c[i]=c[i]>c[i-j]?c[i]:c[i-j];
        }
        i+=lowbit(i);
    }
}
int query(int l,int r){//查询
    int res=INT_MIN;
    while(true){
        res=res>a[r]?res:a[r];
        if(l==r)break;//找完了就退出,在更新数据后再退出防止出错
        for(r-=1;r-l>=lowbit(r);r-=lowbit(r))
            res=res>c[r]?res:c[r];
    }
    return res;
}
int main() {
    ios::sync_with_stdio(false);
    int t;
    cin>>t;
    while(t--){
        int n;
        cin>>n;
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++){
            cin>>a[i];
            c[i]=a[i];
            for(int j=1;j<lowbit(i);j<<=1){//初始化,所有与第i个相关的前置都要更新
                c[i]=c[i]>c[i-j]?c[i]:c[i-j];
            }
        }
        int m;
        cin>>m;
        for(int i=1;i<=m;i++){
            int c,d;
            cin>>c>>d;
            cout<<query(c,d)<<endl;
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值