G - Harmonic Number (II)

I was trying to solve problem '1234 - Harmonic Number', I wrote the following code

long long H( int n ) {
    long long res = 0;
    for( int i = 1; i <= n; i++ )
        res = res + n / i;
    return res;
}

Yes, my error was that I was using the integer divisions only. However, you are given n, you have to find H(n) as in my code.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n < 231).

Output

For each case, print the case number and H(n) calculated by the code.

Sample Input

11

1

2

3

4

5

6

7

8

9

10

2147483647

Sample Output

Case 1: 1

Case 2: 3

Case 3: 5

Case 4: 8

Case 5: 10

Case 6: 14

Case 7: 16

Case 8: 20

Case 9: 23

Case 10: 27

Case 11: 46475828386

题解:我们先将1到sqrt(n)的值暴力加起来。

后面的我们另t=n/i

t=1时有(n/1-n/2)项

t=2时有(n/2-n/3)项

t=3时有 (n/3-n/4)项。。。。。。

再特判n是不是平方数即可

#include<iostream>
#include<stdio.h>
#include<cmath>
using namespace std;
typedef long long ll;
int main()
{
    int t;
    ll n;
    cin>>t;
    int k=1;
    while(t--)
    {
        cin>>n;
        ll ans=0;
        for(int i=1; i<=sqrt(n); i++)
            ans+=n/i;
        for(int i=1; i<=sqrt(n); i++)
        {
            ans+=(ll)((n/i)-(n/(i+1)))*i;
        }

        if((int)sqrt(n) == n/(int)sqrt(n))
            ans-=(int)sqrt(n);
        cout<<"Case "<<k++<<":"<<" "<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值