数据结构实验之二叉树三:统计叶子数

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Sample Input

abc,,de,g,,f,,,

Sample Output

3

Hint

 

Source

xam

题解:左右儿子全为空的节点为叶子节点,遍历树统计即可。

#include<bits/stdc++.h>
using namespace std;
struct node
{
    node *l,*r;
    char data;
};
char a[100];
int top,sum;
node *create()
{
    node *root;
    root=new node;
    top++;
    if(a[top]==',')
        return NULL;
    else
    {
        root=new node;
        root->data=a[top];
        root->l=create();
        root->r=create();
    }
    return root;
}
int getleafsum(node *root)
{
    if(root)
    {
        if(root->l==NULL&&root->r==NULL)
            sum++;
        else
        {
            getleafsum(root->l);
            getleafsum(root->r);
        }
    }
    return sum;
}
int main()
{
    while(cin>>a)
    {
        top=-1;
        sum=0;
        node *root;
        root=create();
        getleafsum(root);
        cout<<sum<<endl;
    }
    return 0;
}


/***************************************************
User name: ACM18171信科1801张林
Result: Accepted
Take time: 0ms
Take Memory: 228KB
Submit time: 2019-02-24 23:33:47
****************************************************/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值