F - Divisibility POJ - 1745

35 篇文章 0 订阅
22 篇文章 0 订阅

 

Consider an arbitrary sequence of integers. One can place + or - operators between integers in the sequence, thus deriving different arithmetical expressions that evaluate to different values. Let us, for example, take the sequence: 17, 5, -21, 15. There are eight possible expressions: 17 + 5 + -21 + 15 = 16 
17 + 5 + -21 - 15 = -14 
17 + 5 - -21 + 15 = 58 
17 + 5 - -21 - 15 = 28 
17 - 5 + -21 + 15 = 6 
17 - 5 + -21 - 15 = -24 
17 - 5 - -21 + 15 = 48 
17 - 5 - -21 - 15 = 18 
We call the sequence of integers divisible by K if + or - operators can be placed between integers in the sequence in such way that resulting value is divisible by K. In the above example, the sequence is divisible by 7 (17+5+-21-15=-14) but is not divisible by 5. 

You are to write a program that will determine divisibility of sequence of integers.

Input

The first line of the input file contains two integers, N and K (1 <= N <= 10000, 2 <= K <= 100) separated by a space. 
The second line contains a sequence of N integers separated by spaces. Each integer is not greater than 10000 by it's absolute value. 

Output

Write to the output file the word "Divisible" if given sequence of integers is divisible by K or "Not divisible" if it's not.

Sample Input

4 7
17 5 -21 15

Sample Output

Divisible
#include<iostream>
#include<cstring>
#include<stdio.h>
#define mod(x) ((x)<0?(-(x))%k:(x)%k)
#define MOD(x) ((((x)%k)+(k))%k)
using namespace std;
int n,k;
bool dp[11111][111];//dp[i][j]代表前i个数任意加减是否能得到j,1为能,0为否
int a[11111];
int main()
{
    cin>>n>>k;
    for(int i=1;i<=n;i++)
        cin>>a[i];
    dp[1][mod(a[1])]=1;//第一个数只能用加法,将其标记为1代表第二维度的值可得到
    for(int i=2;i<=n;i++)
    {
        for(int j=0;j<k;j++)//枚举前i-1个数能否得到余数j
        {
            if(dp[i-1][j])//如果能得到,则第i步可加可减
            {
                dp[i][MOD(j+a[i])]=1;
                dp[i][MOD(j-a[i])]=1;
            }
        }
    }
    if(dp[n][0])
        puts("Divisible\n");
    else
        puts("Not divisible\n");
    return 0;
}
#include<iostream>
#include<cstring>
#include<stdio.h>
#define mod(x) ((x)<0?(-(x))%k:(x)%k)
#define MOD(x) ((((x)%k)+(k))%k)
using namespace std;
int n,k;
bool dp[2][111];//0代表减法,1代表加法
int a[11111];
int main()
{
    cin>>n>>k;
    for(int i=1;i<=n;i++)
        cin>>a[i];
    dp[1][MOD(a[1])]=1;//第一个数只能用加法,将其标记为1代表第二维度的值可得到
    for(int i=2;i<=n;i++)
    {
        memset(dp[i&1],0,sizeof(dp[i&1]));
        for(int j=0;j<k;j++)
        {
            int t1=MOD(j+a[i]);
            int t2=MOD(j-a[i]);
            dp[i&1][t1]=max(dp[i&1][t1],dp[(i-1)&1][j]);//前i-1步任意加减取余的结果已被标记,如果能取到j说明此步可加可减
                                                        //虽说第一维只有0、1两种取值,但这已经足够!
            dp[i&1][t2]=max(dp[i&1][t2],dp[(i-1)&1][j]);//这里是bool类型最大为1表示可取到
        }
    }
    if(dp[n&1][0])
        puts("Divisible\n");
    else
        puts("Not divisible\n");
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值