D - Mayor's posters(线段树+离散化)

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:

  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.


They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4
如果不会离散化先看这里:https://blog.csdn.net/weixin_43061009/article/details/82083983

题意:给出n个区间L[i]到R[i],每一个区间对应一个值,下一个区间如果与前面的区间有重合则会覆盖住前面的区间,我们要找到最后能看到几个不同的值。

题解:区间大小范围较大至10000000,而n只有10000,所以我们可以将这些离散的点转化较紧密的点,保持相对的大小。

感受:思维很清晰的一道题!!!

#include<iostream>
#include<algorithm>
#include<cstring>
#include<stdio.h>
using namespace std;
const int maxn=10010;
int l[maxn],r[maxn],vis[maxn],a[maxn<<1],sum[maxn<<3];
int n,t,top,ans;
void Init()
{
    top=0;
    ans=0;
    memset(vis,0,sizeof(vis));
    memset(sum,0,sizeof(sum));
}
void pushdown(int rt) //下放到子节点,并将自身取消标记
{
    sum[rt*2]=sum[rt*2+1]=sum[rt];
    sum[rt]=0;
}
void update(int L,int R,int w,int l,int r,int rt)
{
    if(L<=l&&R>=r)
    {
        sum[rt]=w;
        return ;
    }
    if(sum[rt])//如果出现过才下放
        pushdown(rt);
    int mid=(l+r)/2;
    if(L<=mid)
        update(L,R,w,l,mid,rt*2);
    if(R>=mid+1)
        update(L,R,w,mid+1,r,rt*2+1);
}
void query(int l,int r,int rt)
{
    if(l==r&&!sum[rt])//如果是子节点并且这个节点没有被标记则可跳过
        return ;
    if(sum[rt])//sum[rt]上的值能被看到
    {
        vis[sum[rt]]=1;//将其标记
        return ;
    }
    int mid=(l+r)/2;
    query(l,mid,rt*2);
    query(mid+1,r,rt*2+1);
}
int main()
{

    cin>>t;
    while(t--)
    {
        Init();
        cin>>n;
        for(int i=1;i<=n;i++)
        {
            cin>>l[i]>>r[i];
            a[top++]=l[i];
            a[top++]=r[i];
        }
        sort(a,a+top);
        int m=unique(a,a+top)-a;    //这里去不去重都可以
        for(int i=1;i<=n;i++)       //离散化
        {
            l[i]=lower_bound(a,a+m,l[i])-a+1;//注意这里为了方便加上1将其下标从1开始
            r[i]=lower_bound(a,a+m,r[i])-a+1;
        }
        for(int i=1;i<=n;i++)       //依次更新每个区间
            update(l[i],r[i],i,1,m,1);
        query(1,m,1);
        for(int i=1;i<=n;i++)//寻找能看到的海报的个数
        {
            if(vis[i])
                ans++;
        }
        cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值