问题 A: Speech Patterns

《算法笔记》6.4小节-map的常见用法详解

问题 A: Speech Patterns
题目描述
People often have a preference among synonyms of the same word. For example, some may prefer “the police”, while others may prefer “the cops”. Analyzing such patterns can help to narrow down a speaker’s identity, which is useful when validating, for example, whether it’s still the same person behind an online avatar.
Now given a paragraph of text sampled from someone’s speech, can you find the person’s most commonly used word?
输入
Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return ‘\n’. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].
输出
For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a “word” is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.
Note that words are case insensitive.
样例输入
Can1: “Can a can can a can? It can!”
样例输出
can 5

#include<iostream> 
#include<string>
#include<map>
using namespace std;
bool check(char c){
	if(c>='0'&&c<='9') return true;
	if(c>='A'&&c<='Z') return true;
	if(c>='a'&&c<='z') return true;
	return false;
}
int main()
{
	map<string,int> count;
	string str;
	getline(cin,str);//读入整行字符串
	int i=0;
	while(i<str.length()){
		string word;
	while(i<str.length()&&check(str[i])==true){
		if(str[i]>='A'&&str[i]<='Z'){
			str[i]+=32;
		}
		word+=str[i];
		i++;
	}
	if(word !=""){
		if(count.find(word)==count.end()) count[word]=1;
		else count[word]++;
	}
		while(i<str.length()&&check(str[i])==false){
			i++;
		}
	}
	string ans;
	int max=0;
	for(map<string,int>::iterator it=count.begin();it!=count.end();it++)
    {
       //cout<<it->first;
	  // printf(" %d\n",it->second);
	  if(it->second>max){
	 	max=it->second;
	 	ans=it->first;
	 }
	}	
	cout<<ans<<" "<<max<<endl; 
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
3.4 Feature Engineering Feature engineering is the process of selecting and transforming raw data into features that can be used by a machine learning algorithm. In our case, we used various NLP techniques to extract features from the GeoNames data. We first extracted the name, feature class, and feature code of each GeoNames record. We then used a part-of-speech (POS) tagger to identify the parts of speech of each word in the name field. We also used a named entity recognizer (NER) to identify the entities in the name field, such as countries, cities, and rivers. We then created several new features based on the extracted information. For example, we created a feature that indicated whether the record was a country or not. We also created features that indicated the number of words in the name field, the number of entities in the name field, and the average length of the words in the name field. In addition to the NLP-based features, we also created several other features. For example, we created a feature that indicated the distance of each record from the equator, as this is known to be a strong predictor of climate and vegetation patterns. We also created features that indicated the population density and area of each record. Finally, we used a feature selection algorithm to select the most important features for our machine learning algorithm. We used a random forest classifier, which is a type of ensemble learning algorithm that combines multiple decision trees to improve performance. We found that the most important features were the feature class, distance from the equator, population density, and number of entities in the name field. Overall, our feature engineering process helped us to extract meaningful information from the raw GeoNames data and create features that were useful for our machine learning algorithm.

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值