Hdoj 1686 Oulipo、KMP:【题解】

Oulipo

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 29736 Accepted Submission(s): 11376

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

题目一大串没必要看了,你只需要知道这是KMP、在文本串中寻找模式串出现次数。用我前边写的KMP模板,在kmp函数中返回的地方做一下修改。本题主要用到了kmp和next数组的求法,然后在那基础上进行修改,要理解kmp函数中while语句模式串的回溯规则。 那先看一下代码:

AC代码:

#include <iostream>
#include <cstdio>
#include <string.h>
#include <algorithm>
using namespace std;
char t[1000005];		//********* 数组空间没开够还wa了两次 
char p[10005];
int nxt[10005];
//建立公共前后缀表, /*****next[j] = k 代表p[j] 之前的模式串子串中,有长度为k 的相同前缀和后缀*****/
void GetNext(char p[], int nxt[]){	// 
	int i, j;
	int m = strlen(p);
	nxt[0] = 0;
	for(j = 1, i = 0; j < m; j++){	//前缀 i,从0开始 后缀j,从1开始 
		while(i > 0 && p[j] != p[i])
			i = nxt[i-1];
		if(p[j] == p[i]){			//前后匹配时,next就加一 
			i++;
		}
		nxt[j] = i;	//①p[j] != p[i] && i == 0,赋值0
					//②p[j] == p[i] && i == 0,i已经加一(i在原匹配串上增加) 
	}				//③p[j] == p[i] && i != 0,回溯过后,给值为第一次匹配的后一位 
} 
int kmp(char t[], char p[], int nxt[]){
	unsigned long n, m;
	int i, q, count = 0;
	n = strlen(t);
	m = strlen(p);
	GetNext(p, nxt);	 
	for(i = 0, q = 0; i < n; i++){	//i == n时结束			// i是text串下标, q是p串下标
		while(q > 0 && p[q] != t[i])
			q = nxt[q-1];			// q-1前边的时公共前后缀,已经无需再比较,和p[nxt[q-1]]比较就行了 
		if(p[q] == t[i]){
			if(p[q] == t[i]){		// 匹配不断后移q和i(i在for循环中已经移动) 
				q++;
			}
			if(q == m)
				count++;	
		} 
	}
	return count;		
}
int main(){
	int T;
	ios::sync_with_stdio(false);	//应该可以去掉
	scanf("%d", &T);
	while(T--){
		scanf("%s", p);
		scanf("%s", t);
		int ans = kmp(t, p, nxt);
		printf("%d\n", ans);
	}
	return 0;
}

kmp函数的这一部分:

	if(q == m)
		count++;

当q==m时,说明模式串p已经匹配到最后一位,count作为计数器就可以++。
有人和我一样也想过为什么改的地方这么简单吗?这就追溯到kmp函数while语句这里nxt[]数组的含义了,因为此时i已经++,指向了下一位了,走while语句时q回溯的位置时nxt[q - 1],这个q - 1代表的就是相同前后缀之后的第一个字符。
举个例子吧:
text:ABCABCAB
p: ABCAB (nxt数组分别是:00012)
当比完第一次count++后,i指向text串的C,而nxt[q - 1] = 2,让q = nxt[q - 1]就让p[q]指向了C,省去了p串C前边AB的比较。

注意: 在代码中我的next都用nxt表示了,避免与C++中的next产生混淆和不必要的麻烦。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值