Poj 1287 Networking、最小生成树、kruskal:【题解】

Networking

Time Limit: 1000MS Memory Limit: 10000K

Description

You are assigned to design network connections between certain points in a wide area. You are given a set of points in the area, and a set of possible routes for the cables that may connect pairs of points. For each possible route between two points, you are given the length of the cable that is needed to connect the points over that route. Note that there may exist many possible routes between two given points. It is assumed that the given possible routes connect (directly or indirectly) each two points in the area.
Your task is to design the network for the area, so that there is a connection (direct or indirect) between every two points (i.e., all the points are interconnected, but not necessarily by a direct cable), and that the total length of the used cable is minimal.

Input

The input file consists of a number of data sets. Each data set defines one required network. The first line of the set contains two integers: the first defines the number P of the given points, and the second the number R of given routes between the points. The following R lines define the given routes between the points, each giving three integer numbers: the first two numbers identify the points, and the third gives the length of the route. The numbers are separated with white spaces. A data set giving only one number P=0 denotes the end of the input. The data sets are separated with an empty line.
The maximal number of points is 50. The maximal length of a given route is 100. The number of possible routes is unlimited. The nodes are identified with integers between 1 and P (inclusive). The routes between two points i and j may be given as i j or as j i.
Output

For each data set, print one number on a separate line that gives the total length of the cable used for the entire designed network.

Sample Input

1 0

2 3
1 2 37
2 1 17
1 2 68

3 7
1 2 19
2 3 11
3 1 7
1 3 5
2 3 89
3 1 91
1 2 32

5 7
1 2 5
2 3 7
2 4 8
4 5 11
3 5 10
1 5 6
4 2 12

0

Sample Output

0
17
16
26

中文题意:

存在许多点和点与点之间的路径,路径长度不一,点到点之间可能存在多条路径。挑选部分路径使得所有点连通且总路径长度最小。
多样例输入。每个样例都保证有解。
每个样例的第一行有两个整数,P(点的个数),R(点与点之间的路径总数)。
接下来的R行输入路径,每行含3个整数,前两个数表示连接的两个点,第三个数表示路径长度。当P为0时输入结束。样例与样例之间存在空行。P最大为50,路径长度最大为100,路径数没有限制。i和j之间的路径可以表示为 i j 或 j i

分析:裸kruskal,记录一下我对kruskal的慢慢理解过程,unions函数是使用并查集判断:x和y这两个点是否在同一个联通分量里,只有它们不在同一个连通分量才能连接起来,构不成环。

AC代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
const int N = 55;
const int maxx = 3e5;
int dis[N][N];
struct edge{
	int x, y, d;
}e[maxx];
int f[N], n, m;
int get(int x){
	if(f[x] == x)	return x;
	return f[x] = get(f[x]);
}
bool unions(int x, int y){
	int rx = get(x), ry = get(y);
	if(rx != ry){
		f[rx] = ry;
		return true;
	}
	return false;
}
bool cmp(edge a, edge b){
	return a.d < b.d;
}
int main(){
	while(scanf("%d", &n)){
		if(n == 0)	break;
		scanf("%d", &m);
		for(int i = 1; i <= n; i++)
			f[i] = i;
		for(int i = 1; i <= n; i++){
			for(int j = 1; j <= n; j++){
				dis[i][j] = inf;
			}
			dis[i][i] = 0;
		}
		for(int i = 1; i <= m; i++){
			scanf("%d%d%d", &e[i].x, &e[i].y, &e[i].d);
		}
			
		sort(e + 1, e + 1 + m, cmp);
		int ans = 0, num = 0;
		for(int i = 1; i <= m; i++){
			if(unions(e[i].x, e[i].y)){
				ans += e[i].d;
				num ++;
				if(num == n - 1)	break;
			}
		}
		cout << ans << endl;
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值