Escape

题目

2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets. 

Input

More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet. 
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most.. 
0 <= ai <= 100000 

Output

Determine whether all people can live up to these stars 
If you can output YES, otherwise output NO. 

样例

Sample Input

1 1
1
1

2 2
1 0
1 0
1 1

Sample Output

YES
NO

这道题,我乍一看不就是简单的网络流嘛,然后没想到疯狂TLE,才发现没这么简单,因为它的测试数据特别大,必须要特别处理一下,把一样的点合并一下!

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cmath>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <vector>
#include <string.h>
#include <string>
typedef long long ll;
#define INF 0x3f3f3f3f
using namespace std;
#define maxn 100110
#define maxm 4000110

struct node {
	int to, next, cap;
}edge[maxm];
int tol;
int head[maxn];
int dis[maxn];
int gap[maxn];
int cur[maxn], pre[maxn];

void init() {
	tol = 0;
	memset(head, -1, sizeof(head));
}

void addedge(int u, int v, int w, int rw = 0) {
	edge[tol].to = v; edge[tol].cap = w; edge[tol].next = head[u]; head[u] = tol++;
	edge[tol].to = u; edge[tol].cap = rw; edge[tol].next = head[v]; head[v] = tol++;
}

int sap(int start, int end, int nodenum) {
	memset(dis, 0, sizeof(dis));
	memset(gap, 0, sizeof(gap));
	memcpy(cur, head, sizeof(head));
	int u = pre[start] = start, maxflow = 0, aug = -1;
	gap[0] = nodenum;
	while (dis[start] < nodenum){
	loop:
		for (int& i = cur[u]; i != -1; i = edge[i].next){
			int v = edge[i].to;
			if (edge[i].cap && dis[u] == dis[v] + 1){
				if (aug == -1 || aug > edge[i].cap)
					aug = edge[i].cap;
				pre[v] = u;
				u = v;
				if (v == end){
					maxflow += aug;
					for (u = pre[u]; v != start; v = u, u = pre[u])	{
						edge[cur[u]].cap -= aug;
						edge[cur[u] ^ 1].cap += aug;
					}
					aug = -1;
				}
				goto loop;
			}
		}
		int mindis = nodenum;
		for (int i = head[u]; i != -1; i = edge[i].next){
			int v = edge[i].to;
			if (edge[i].cap && mindis > dis[v]){
				cur[u] = i;
				mindis = dis[v];
			}
		}
		if ((--gap[dis[u]]) == 0)break;
		gap[dis[u] = mindis + 1]++;
		u = pre[u];
	}
	return maxflow;
}

int num[1025];
int a[11];
int bit[11];

int main(){
	bit[0] = 1;
	for (int i = 1; i <= 10; i++)bit[i] = bit[i - 1] * 2;
	int n, m;
	while (scanf("%d%d", &n, &m) != EOF){
		init();
		memset(num, 0, sizeof(num));
		for (int i = 1; i <= n; i++){
			int tmp = 0;
			for (int j = 0; j < m; j++) { 
				scanf("%d", &a[j]); tmp += a[j] * bit[j]; 
			}
			num[tmp]++;
		}
		int start = 0, end = 1024 + m + 1, nodenum = 2014 + m + 2;
		for (int i = 0; i < 1024; i++){
			if (num[i] == 0)continue;
			addedge(start, i + 1, num[i]);
			for (int j = 0; j < 10; j++)
				if (i & bit[j])
					addedge(i + 1, 1024 + j + 1, INF);
		}
		int tmp;
		for (int i = 1; i <= m; i++){
			scanf("%d", &tmp);
			addedge(i + 1024, end, tmp);
		}
		if (sap(start, end, nodenum) == n)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值