HDU1004 Let The Balloon Rise

HDU1004 Let The Balloon Rise Java解决
问题分析:
这道题解法的关键就在这个for循环里面:
for(int j=0;j<n;j++)
{
if(j==0)
a[j]++;
else
{
for(int k=j-1;k>=0;k–)
{
if(input[j].equals(input[k]))
a[j]++;
}
}
}
把所有的颜色一个个比较,第一个不用比较,从第二个开始每个比较n-1次,所以嵌套了一个for循环,如果相同,则整形数组对应的下标+1。
问题原型:
Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

代码如下:

import java.util.Scanner;
public class Main {
    public static void main(String[] args)
    {
        Scanner in=new Scanner(System.in);
        while(in.hasNext())
        {
            int n=in.nextInt();
            in.nextLine();
            if(n==0)
                break;
            String[] input=new String[n];
            int[] a=new int[n];
            for(int i=0;i<n;i++)
            {
                input[i]=in.nextLine();
            }
            for(int j=0;j<n;j++)
            {
                if(j==0)
                    a[j]++;
                else
                {
                    for(int k=j-1;k>=0;k--)
                    {
                        if(input[j].equals(input[k]))
                            a[j]++;
                    }
                }
            }
            int Maxnum = 0,position=0;
            for(int x=0;x<n;x++)
            {
                if(x==0)
                    Maxnum=a[x];
                else
                {
                    if(a[x]>=Maxnum)
                    {
                        Maxnum=a[x];
                        position=x;
                    }
                        
                }
            }
            System.out.println(input[position]);
        }
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值