Description
Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.
Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).
Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).
But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. _
Input
Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.
Process to the end of file.
Output
Output the maximal summation described above in one line.
Sample Input
1 3 1 2 3
2 6 -1 4 -2 3 -2 3
Sample Output
6
8
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int MAXN=1e6+1;
int dp[MAXN],pre_max[MAXN];
int a[MAXN];
int main(){
//freopen("/Users/guoyu/Desktop/algorithm/in.txt","r",stdin);
int n,m;
while(~scanf("%d %d",&m,&n)){
for(int i=1;i<=n;i++){
scanf("%d",a+i);
dp[i]=pre_max[i]=0;
}
int tmp;
for(int j=1;j<=m;j++){
tmp=-1e9;
for(int i=j;i<=n;i++){
dp[i]=a[i]+max(dp[i-1],pre_max[i-1]);
pre_max[i-1]=tmp;
tmp=max(tmp,dp[i]);
}
}
printf("%d\n",tmp);
}
return 0;
}