1035 Password (20分)

1035 Password

o prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1 team110 abcdefg332

Sample Output 2:

There is 1 account and no account is modified

Sample Input 3:

2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

There are 2 accounts and no account is modified

题意:输入多组实例,包含ID和password两个字符串,如果出现’0’、‘1’、‘l’、'O’等4个字符就用特殊符号进行替换,输出需要修正的账户数及修正后的信息;如果无需修正则输出“There are N accounts and no account is modified ”(埋雷点,写完因为没注意A不了)

难点易错点:
(1)题目要求在所有信息输入后进行是否需要修正的判断后,在输出对应得信息,所以每一个字符串都应该保存,因此使用一个结构体数组进行记录需要修正的实例,方便最后输出;
(2)判断是否需要修正,一开始思路用一个bool flag = false 进行标记如果没有进入if条件则改true,但实际只看最后一个字符有无修改;
灵机一动改用 int flag = strlen(temp.password);遍历过程中无修改,则自减,最后如果flag == 0;那么必定无字符修改过,代码就变得简洁多了。
(3)错误点:无需修改时,1个和>1个的情况输出的语句是不一样的,好好审题

附上最后代码:

#include<bits/stdc++.h>
struct user{
    char id[11],password[11];
}modified[1001],temp;
int main()
{
    int n,count = 0;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        scanf("%s %s",temp.id,temp.password);
        int len = strlen(temp.password);
        int flag = len;
        for(int i = 0;i < len ; i++){
            if( temp.password[i] == '1' ) temp.password[i] = '@';
            else if( temp.password[i] == '0' ) temp.password[i] = '%';
            else if( temp.password[i] == 'O' ) temp.password[i] = 'o';
            else if( temp.password[i] == 'l' ) temp.password[i] = 'L';
            else flag--;
        }
        if( flag != 0 ) modified[count++] = temp;
    }
    if (count == 0 ){
        if(n==1) printf("There is %d account and no account is modified",n);
        else printf("There are %d accounts and no account is modified",n);
    }
    else{
        printf("%d\n",count);
        for(int i = 0 ; i < count; i++){
            printf("%s %s\n",modified[i].id,modified[i].password);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值