大数相加

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B. 

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000. 

Output

For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases. 

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

 

【代码】

#include<iostream>
#include<cstring>
#include<cstdlib>
using namespace std;
const int maxn = 1000;
char str1[maxn], str2[maxn];
int  num1[maxn], num2[maxn];
void sum() {
    for(int i = strlen(str1)-1,j = 0; i >= 0; i--) {
        num1[j++] = str1[i] - '0';
    }
    for(int i = strlen(str2)-1, j = 0; i >= 0; i--) {
        num2[j++] = str2[i] - '0';
    }
    for(int i = 0; i < maxn; i++) {
        num2[i] += num1[i];
        if(num2[i] >= 10) {
            num2[i+1] += num2[i]/10;
            num2[i] %= 10;
        }
    }
    int i;
    for(i = maxn-1; i >= 0 && num2[i] == 0; i--);
    if(i >= 0) {
        for(; i >= 0; i--) {
            cout<<num2[i];
        }
    } else {
        cout<<0;
    }
    cout<<endl;
}
int main() {
    int t,kase=0;
    cin>>t;
    while(t--){
        memset(num1, 0, sizeof(num1));
        memset(num2, 0, sizeof(num2));
        memset(str1, 0, sizeof(str1));
        memset(str2, 0, sizeof(str2));
        cin>>str1>>str2;
        if(kase)printf("\n");
        printf("Case %d:\n%s + %s = ", ++kase, str1, str2);
        sum();
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值