Recursive sequence HDU - 5950(递推式构造矩阵+矩阵快速幂)

Farmer John likes to play mathematics games with his N cows. Recently, they are attracted by recursive sequences. In each turn, the cows would stand in a line, while John writes two positive numbers a and b on a blackboard. And then, the cows would say their identity number one by one. The first cow says the first number a and the second says the second number b. After that, the i-th cow says the sum of twice the (i-2)-th number, the (i-1)-th number, and i4. Now, you need to write a program to calculate the number of the N-th cow in order to check if John’s cows can make it right.
Input
The first line of input contains an integer t, the number of test cases. t test cases follow.
Each case contains only one line with three numbers N, a and b where N,a,b < 231 as described above.
Output
For each test case, output the number of the N-th cow. This number might be very large, so you need to output it modulo 2147493647.
Sample Input
2
3 1 2
4 1 10
Sample Output
85
369

题意:

给出了一个递推式 f(n)=2*f(n-2)+f(n-1)+n^4;让你求这个式子的第n项是多少;
思路 :

当然是用矩阵快速幂,但是难点在于初始矩阵的构造,点传送门你会明白的:戳一戳

这里就不多解释了 上代码;

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
 using namespace std;
 typedef long long ll;
 const ll mod=2147493647;
struct node
{
    ll ma[11][11];
};
 node mul(node a,node b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
    for(int i=0;i<7;i++)
        for(int j=0;j<7;j++)
         for(int k=0;k<7;k++)
            ans.ma[i][j]=(ans.ma[i][j]+a.ma[i][k]*b.ma[k][j])%mod;
    return ans;
 }
 node pow(node a,int b)
 {
     node ans;
     memset(ans.ma,0,sizeof ans.ma);
     for(int i=0;i<7;i++) ans.ma[i][i]=1;
     while(b)
     {
         if(b&1) ans=mul(ans,a);
         a=mul(a,a);
         b>>=1;
     }
     return ans;
 }
int main(){

    node a;
    memset(a.ma,0,sizeof(a.ma));
    a.ma[0][1] = 1;
    a.ma[1][1] = a.ma[1][2] = a.ma[1][6] = 1;
    a.ma[2][2] = a.ma[2][6] = 1;
    a.ma[1][0] = 2; a.ma[1][3] = a.ma[1][5] = a.ma[2][3] = a.ma[2][5] = 4;
    a.ma[1][4] = a.ma[2][4] = 6;
    a.ma[3][3] = a.ma[4][4] = a.ma[5][5] = a.ma[6][6] = 1;
    a.ma[3][6] = a.ma[4][6] = a.ma[5][6] = 1;
    a.ma[3][4] = a.ma[3][5] = 3;
    a.ma[4][5] = 2;
    int t;
    scanf("%d",&t);
    ll n,aa,bb;
    node b;
    while(t--){
        scanf("%lld%lld%lld",&n,&aa,&bb);
        if(n==1){
            printf("%lld\n",aa%mod);
        }
        else if(n==2){
            printf("%lld\n",bb%mod);
        }
        else{

            node ans = pow(a,n-2);
            ll ANS = 0;
            ANS = (ANS+ans.ma[1][0]*aa)%mod;
            ANS = (ANS+ans.ma[1][1]*bb)%mod;
            ANS = (ANS+ans.ma[1][2]*16)%mod;
            ANS = (ANS+ans.ma[1][3]*8)%mod;
            ANS = (ANS+ans.ma[1][4]*4)%mod;
            ANS = (ANS+ans.ma[1][5]*2)%mod;
            ANS = (ANS+ans.ma[1][6]*1)%mod;
            printf("%I64d\n",ANS);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值