ZZULIOJ C,Java,Python,C++,代码总结 1000: 整数a+b

**

题目描述

计算两个整数的和。
输入
输入两个整数,两个整数用空格隔开。
输出
输出为两个整数的和,单独占一行。
样例输入 Copy
1 1
样例输出 Copy
2

**

C


#include <stdio.h>
int main(){
    int a,b;
    scanf("%d %d",&a, &b); 
        printf("%d\n",a+b);
    return 0;
}

JAVA

import java.util.*;
/*需要注意在ZZULIOJ上java的类名必须为Main*/
public class Main{
	public static void main(String args[]){
		Scanner cin = new Scanner(System.in);
		int a, b;
		while (cin.hasNext()){
			a = cin.nextInt(); b = cin.nextInt();
			System.out.println(a + b);
		}
	}
}

C++

#include <iostream>
using namespace std;
int main(){
    int a,b;
    while(cin >> a >> b)
        cout << a+b << endl;
    return 0;
}

Python

while True:
    a=[]
    line = input()
    a=[int(n) for n in line.split()]
    if a:
        print (a[0]+a[1])
    else:
        break
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值