Holy Grail

https://nanti.jisuanke.com/t/41305

  • spfa 学习http://keyblog.cn/article-21.html
     38.59%
    1000ms
    262144K 

As the current heir of a wizarding family with a long history,unfortunately, you find yourself forced to participate in the cruel Holy Grail War which has a reincarnation of sixty years.However,fortunately,you summoned a Caster Servant with a powerful Noble Phantasm.When your servant launch her Noble Phantasm,it will construct a magic field,which is actually a directed graph consisting of n vertices and m edges.More specifically,the graph satisfies the following restrictions :

    Does not have multiple edges(for each pair of vertices x and y, there is at most one edge between this pair of vertices in the graph) and does not have self-loops(edges connecting the vertex with itself).
    May have negative-weighted edges.
    Does not have a negative-weighted loop.
    n<=300 , m<=500.

Currently,as your servant's Master,as long as you add extra 6 edges to the graph,you will beat the other 6 masters to win the Holy Grail.

However,you are subject to the following restrictions when you add the edges to the graph:

    Each time you add an edge whose cost is c,it will cost you c units of Magic Value.Therefore,you need to add an edge which has the lowest weight(it's probably that you need to add an edge which has a negative weight).
    Each time you add an edge to the graph,the graph must not have negative loops,otherwise you will be engulfed by the Holy Grail you summon.

Input

Input data contains multiple test cases. The first line of input contains integer t — the number of testcases (1≤t≤51 \le t \le 51≤t≤5).

For each test case,the first line contains two integers n,m,the number of vertices in the graph, the initial number of edges in the graph.

Then m lines follow, each line contains three integers x, y and w (0≤x,y<n0 \le x,y<n0≤x,y<n,−109-10^9−109≤w≤10910^9109, x=yx \not = yx​=y) denoting an edge from vertices x to y (0-indexed) of weight w.

Then 6 lines follow, each line contains two integers s,t denoting the starting vertex and the ending vertex of the edge you need to add to the graph.

It is guaranteed that there is not an edge starting from s to t before you add any edges and there must exists such an edge which has the lowest weight and satisfies the above restrictions, meaning the solution absolutely exists for each query.
Output

For each test case,output 666 lines.

Each line contains the weight of the edge you add to the graph.
样例输入

1
10 15
4 7 10
7 6 3
5 3 3
1 4 11
0 6 20
9 8 25
3 0 9
1 2 15
9 0 27
5 2 0
7 3 -5
1 7 21
5 0 1
9 3 16
1 8 4
4 1
0 3
6 9
2 1
8 7
0 4

样例输出

-11
-9
-45
-15
17
7

SPFA 最短路

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int n,m; 
const ll inf=1e9+10;
const int N=310; 
struct node
{
	int b;
	ll w;
};
vector<node>v[N];
int vis[N];
ll dis[N];
void spfa(int s)
{
	for(int i=0;i<=n;i++)
	{
		vis[i]=0;
		dis[i]=inf;
	}
	dis[s]=0;vis[s]=1;
	queue<int>q;
	q.push(s);
	while(!q.empty())
	{
		int h=q.front();
		q.pop();
		vis[h]=0;
		for(int i=0;i<v[h].size();i++)
		{
			int u=v[h][i].b;ll ww=v[h][i].w;
			if(dis[h]+ww<dis[u])
			{
				dis[u]=dis[h]+ww;
				if(!vis[u])
				{
					vis[u]=1;
					q.push(u);
				}
			}
		}
	}
	return ;
}

int main()
{
	int tt;
	scanf("%d",&tt);
	while(tt--)
	{
      scanf("%d%d",&n,&m);int a,b;ll c;
      for(int i=0;i<m;i++)
      {
      	scanf("%d%d%lld",&a,&b,&c);
      	v[a].push_back(node {b,c});
	  }
	  for(int i=1;i<=6;i++)
	  {
	  	scanf("%d%d",&a,&b);
	  	spfa(b);
	  	ll ans=dis[a];
	  	v[a].push_back(node{b,-ans});
//保证这个条件
//add an edge to the graph,the graph must not have negative loops,
	  	printf("%lld\n",-ans);
	  }
	  for(int i=0;i<=n;i++)
	  {
	  	v[i].clear();
	  }
	} 
}

题意:给你一个 n个点 m条边的有向图,并且保证图中没有负环和重边,需要让你添加6条边的权值,要满足添加后也没有负环,且 权值最小。

题解:没有负环且权值最小,比如你知道从1->6的权值和为15,让你求6->1的最小权重且没有负环,取一个相反数就行 了 -15 ,这就是最小的,环的为0,满足。

参考:https://blog.csdn.net/weixin_43667611/article/details/100187540

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值