C语言实验——某年某月的天数

Problem Description
输入年和月,判断该月有几天?
Input
输入年和月,格式为年\月。
Output
输出该月的天数。
Sample Input
2009\1
Sample Output
31
Hint
注意判断闰年啊
Source

#include <stdio.h>
#include <stdlib.h>

int main()
{
    int year,month;
    scanf("%d\\%d",&year,&month);
    if(month==1||month==3||month==5||month==7||month==8||month==10||month==12)printf("31\n");
    if(month==4||month==6||month==9||month==11)printf("30\n");
    if(month==2)
    {if((year%4==0&&year%100!=0)||year%400==0)printf("29\n");
    else printf("28\n");
    }
    return 0;
}

  • 5
    点赞
  • 8
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值