POJ - 2559(单调栈的应用)

题目链接

题目描述

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles:
poj2559

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.

Input

The input contains several test cases. Each test case describes a histogram and starts with an integer n, denoting the number of rectangles it is composed of. You may assume that 1<=n<=100000. Then follow n integers h1,…,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is 1. A zero follows the input for the last test case.

Output

For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.

Sample Input

1
2
3
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0

Sample Output

1
2
8
4000

Hint

Huge input, scanf is recommended.

题解

这题算是单调栈典型应用题了吧

题意: 在直方图中找到最大矩阵,并求出其面积。
思路: 最直接的想法就是暴力(Brute Force), 求出某个矩阵的最大左拓展个最大右拓展,但是这样会有很多重复计算的过程, 此时间复杂度是O(n ^ 2) , 铁定超时。

然后我们的想法就是尽量减少这种重复, 然后就要用单调栈了, 何为单调栈,顾名思义 就是栈内元素是单调的。

单调栈中存两个key值, 这个矩形的高度, 和其最左宽度(向左拓展的最大距离的索引)。

当新元素的高度大于栈顶元素的高度时, 直接入栈。
小于等于时, 弹出栈顶元素, 并计算弹出栈顶元素的最大拓展面积, 取最大值, 弹出, 在比较。

AC代码:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
//#include <bits/stdc++.h>
#include <iostream>
#include <stack>
#include "algorithm"
#include "cstdio"
#include "queue"
#include "set"
#include "cstring"
#include "string"
#include "map"
#include "vector"
#include "math.h"
#include "utility"   // pair头文件
#define esp 1e-6
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int INF = 0x3f3f3f3f;
const int N = 1e5 + 5;
struct node{
    ll height;
    int width;
    node(){
        height = 0;
        width = 0;
    }//初始化, 其实不要也可
};
stack <node> st;
int main(){
    int n;
    node a;
    while(cin >> n){
        if (n == 0)
            break;
        ll ans = 0;
        for (int i = 1; i <= n + 1; i++){
            if (i <= n)
                scanf("%lld", &a.height);
            else
                a.height = 0;  // 最后加入一个0元素, 使栈全部元素弹出, 巧妙啊
            a.width = i;
            while(!st.empty() && st.top().height >= a.height) {
                ans = max(ans, st.top().height * (i - st.top().width));
                a.width = st.top().width;
                st.pop();
            }
            st.push(a);
        }
        cout << ans << "\n";
    }
    return 0;
}
1
恰似你一低头的温柔,娇弱水莲花不胜寒风的娇羞, 我的心为你悸动不休。  --mingfuyan
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值