04-树6 Complete Binary Search Tree (30分)

题目

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

代码

#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<queue>
#include<cmath>
typedef struct TreeNode *CTree;
struct TreeNode{
	int v;
	CTree left,right;
};
using namespace std;
CTree Insert(CTree T,int v){
	if(!T){
		T=(CTree)malloc(sizeof(struct TreeNode));
		T->v=v;T->left=NULL;T->right=NULL;
	}
	else{
		if(v<T->v) T->left=Insert(T->left,v);
		else if(v>T->v) T->right=Insert(T->right,v);
	}
	return T;
}
CTree Find(CTree T,int v){
	if(T->v==v)return T;
	else{
		if(v<T->v) return Find(T->left,v);
		else if(v>T->v) return Find(T->right,v);
		else return NULL;
	}
}
void CBST(int t[],CTree &T,int start,int n){//分治法
	if(!n) return;
	int flr=floor(log(n)/log(2));
	int zuo,you,root;
	if(pow(2,flr)-1<n){//找出左子树结点数和右子树结点数
		if(n-(pow(2,flr)-1)<pow(2,flr-1)){
			zuo=(pow(2,flr)-2)/2+n-(pow(2,flr)-1);
			you=n-zuo-1;
		}
		else{
			zuo=(pow(2,flr)-2)/2+pow(2,flr-1);
			you=n-zuo-1;
		}
	}
	else{
		zuo=(n-1)/2;
		you=zuo;
	}
	root=start+zuo;//确定根的位置
	T=Insert(T,t[root]);//放入二叉树
	CBST(t,T,root-zuo,zuo);//处理左子树
	CBST(t,T,root+1,you);//处理右子树
}
int main(){
	queue<int> q;
	CTree T=NULL;
	int n;cin>>n;
	int t[n];
	for(int i=1;i<=n;i++)cin>>t[i];
	sort(t+1,t+n+1);
	//for(int i=1;i<=n;i++)cout<<t[i];
	CBST(t,T,1,n);
	q.push(T->v);
	CTree R=T;
	int flag=0;
	while(!q.empty()){
		if(flag)cout<<" ";
		else flag=1;
		T=Find(R,q.front());
		if(T->left)q.push(T->left->v);
		if(T->right)q.push(T->right->v);
		cout<<q.front();
		q.pop();
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
对于计算机专业的学生而言,参加各类比赛能够带来多方面的益处,具体包括但不限于以下几点: 技能提升: 参与比赛促使学生深入学习和掌握计算机领域的专业知识与技能,如编程语言、算法设计、软件工程、网络安全等。 比赛通常涉及实际问题的解决,有助于将理论知识应用于实践中,增强问题解决能力。 实践经验: 大多数比赛都要求参赛者设计并实现解决方案,这提供了宝贵的动手操作机会,有助于积累项目经验。 实践经验对于计算机专业的学生尤为重要,因为雇主往往更青睐有实际项目背景的候选人。 团队合作: 许多比赛鼓励团队协作,这有助于培养学生的团队精神、沟通技巧和领导能力。 团队合作还能促进学生之间的知识共享和思维碰撞,有助于形成更全面的解决方案。 职业发展: 获奖经历可以显著增强简历的吸引力,为求职或继续深造提供有力支持。 某些比赛可能直接与企业合作,提供实习、工作机会或奖学金,为学生的职业生涯打开更多门路。 网络拓展: 比赛是结识同行业人才的好机会,可以帮助学生建立行业联系,这对于未来的职业发展非常重要。 奖金与荣誉: 许多比赛提供奖金或奖品,这不仅能给予学生经济上的奖励,还能增强其成就感和自信心。 荣誉证书或奖状可以证明学生的成就,对个人品牌建设有积极作用。 创新与研究: 参加比赛可以激发学生的创新思维,推动科研项目的开展,有时甚至能促成学术论文的发表。 个人成长: 在准备和参加比赛的过程中,学生将面临压力与挑战,这有助于培养良好的心理素质和抗压能力。 自我挑战和克服困难的经历对个人成长有着深远的影响。 综上所述,参加计算机领域的比赛对于学生来说是一个全面发展的平台,不仅可以提升专业技能,还能增强团队协作、沟通、解决问题的能力,并为未来的职业生涯奠定坚实的基础。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值