Bad Hair Day POJ - 3250 (dp)

Some of Farmer John’s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows’ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

    =

= =
= - = Cows facing right -->
= = =
= - = = =
= = = = = =
1 2 3 4 5 6
Cow#1 can see the hairstyle of cows #2, 3, 4
Cow#2 can see no cow’s hairstyle
Cow#3 can see the hairstyle of cow #4
Cow#4 can see no cow’s hairstyle
Cow#5 can see the hairstyle of cow 6
Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

Input
Line 1: The number of cows, N.
Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i.
Output
Line 1: A single integer that is the sum of c 1 through cN.
Sample Input
6
10
3
7
4
12
2
Sample Output
5

题意:
不知道为什么上面显示的怪怪的(?)直接说题意好了。

n只牛从左到右排排站,牛i可以看见自己右边的比自己矮的没有被挡住的牛,只数为c[i]。求∑c[i]。

思路:
不知道为什么我一眼看以为肯定是树,其实他不是,他是一个单调栈或者DP。
单调栈就很简单,只要无脑压进去,如果可以压就在答案里面加入栈的大小,如果不可以就把比他小的都弹出去。

dp,其实也算不上什么dp,说是思维题也不为过。一个牛可以看见的牛只有从他开始到第一个比他高的牛这之间的牛。然后维护一个数组,记录比一个牛高的最近的牛。重点是怎么维护。用类似并查集的方式,把比一个牛高的最近的牛看作这个牛的父亲,那么当你要更新他左边的牛的时候,就顺着这个并查集往上,直到遇见第一个比他大的就好了。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<list>
#include<math.h>
#include<vector>
#include<stack>
#include<string>
#include<set>
#include<map>
#include<numeric>
#include<stdio.h>
#include<functional>
#include<time.h>
#pragma warning(disable:6031)

using namespace std;
typedef long long ll;
typedef unsigned long long ull;
const int maxn = 1e5 + 10;
const ll mode = 1e9 + 7;
const int inf = 0x3f3f3f3f;
const double pi = 3.14159265358979323846264338327950;
template <class T> inline T min(T a, T b, T c) { return min(min(a, b), c); }
template <class T> inline T max(T a, T b, T c) { return max(max(a, b), c); }
template <class T> inline T min(T a, T b, T c, T d) { return min(min(a, b), min(c, d)); }
template <class T> inline T max(T a, T b, T c, T d) { return max(max(a, b), max(c, d)); }

int dp[80010];
int h[80010];
int main()
{
	int n;
	while (~scanf("%d", &n))
	{
		for (int i = 0; i < n; i++)
			scanf("%d", &h[i]);
		h[n] = inf;

		for (int i = n - 1; i >= 0; i--)
		{
			int temp = i + 1;
			dp[i] = temp;
			while (h[i] > h[temp])
			{
				dp[i] = dp[temp];
				temp = dp[temp];
			}
		}

		ll ans = 0;
		for (int i = 0; i < n; i++)
			ans += dp[i] - i - 1;
		printf("%lld\n", ans);
	}

	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值