CSU-ACM2019寒假训练2-H - Just Trisearch

这个题其实是三分,但是我按照数学方法来做了,至于三分用的很少,要是感兴趣可以去找找其他的博客,给个链接~
三分的用法详细说明

题目:

Now, here is a fuction:
F(x) = 6 * x7+8*x6+7x3+5*x2-yx (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input
2
100
200

Sample Output
-74.4291
-178.8534

日常翻译:
现在,这是一个功能:
F(x)= 6 * x ^ 7 + 8 * x ^ 6 + 7 * x ^ 3 + 5 * x ^ 2-y * x(0 <= x <= 100)
当x介于0和100之间时,您能找到最小值吗?

输入
输入的第一行包含整数T(1 <= T <= 100),表示测试用例的数量。 然后是T行,每行只有一个实数Y.(0 <Y <1e10)

输出
当x介于0和100之间时,只是最小值(精确到4位小数)。

样本输入
2
100
200

样本输出
-74.4291
-178.8534

思路:这个是个函数,求最小值,那么求导,找到导数接近0的点(double 类型不可能相等的,有误差的,所以判断循环条件的时候就找个精度高的),然后代入原来的式子,输出即可~~

代码如下:(o゚v゚)ノ

#include<cmath>
#include<iostream>
using namespace std;
double getm(double x,double y)
{
 return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;//计算原函数
}
double getn(double x)
{
 return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x;//计算导数
}
int main()
{
	int T;

	cin>>T;
 while(T--)
 {
 	double y,left=0.0,right=100.0,mid;
 	cin>>y;
	while(right-left>1e-7)//找个精度高的作为循环条件
	{
		mid=(left+right)*1.0/2;
		if(getn(mid)>y)
		 right=mid;
		else
		 left=mid;
     }
     printf("%0.4lf\n",getm(mid,y));//最后输出即可啦
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值