习题3-9 子序列

这道题目真的很水欸,还以为越来越难╮(╯▽╰)╭

题目

输入两个字符串s和t,判断是否可以从t中删除0个或者多个字符(其他字符顺序不变),得到字符串t。

样例输入
abcde bce
abcd bc

样例输出
no
yes

代码如下:(:з)∠)

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<string>
using namespace std;
string s,t;
int main()
{
  while(cin>>s>>t)
  {
  int l1,l2,counts=0; 
  l1=s.length();
  l2=t.length();
  for(int i=0;i<l1;i++)
  {
   if(s[i]==t[counts])
   counts++;
  }
  if(counts==l2)//只需最后判断满足的与t字符串长度比较~
  cout<<"yes"<<endl;
  else
  cout<<"no"<<endl;
  }
  return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值