PAT A1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:K N​1​​ a​N​1​ ​​ N​2​​ a​N​2​​ ​​ … N​K​​ a​N​K​​ ​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​ ​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

接下来是AC代码:

#include <stdio.h>
#include <string.h>
int main(int argc, char *argv[]) {
	//幂数最大为1000,设置为1010 
	const int maxn = 1010;
	//count为计数器 
	int k,n,count=0,i;
	//用数组来存储多项式可以省去很多麻烦 
	double p[maxn];
	double a;
	//将数组中所有元素初始化为0 
	memset(p,0,sizeof(p));
	//输入第一行数据并运算 
	scanf("%d",&k);
	for(i=0;i<k;i++){
		scanf("%d %lf",&n,&a);
		p[n]+=a;
	}
	//输入第二行数据并运算 
	//第二行输入完之后即相加成功 
	scanf("%d",&k);
	for(i=0;i<k;i++){
		scanf("%d %lf",&n,&a);
		p[n]+=a;
	}
	//遍历数组,得到项数 
	for(i=0;i<maxn;i++){
		if(p[i]!=0){
			count++;
		}
	}
	//输出 
	printf("%d",count);
	for(i=maxn-1;i>=0;i--){
		if(p[i]!=0){
			printf(" %d %.1lf",i,p[i]);
		}
	}	
	return 0;
}

需要注意:
1.输出时幂次从小到大,格式上需要保留一位小数
2.题目的输入和输出都是系数非零项
3.有些人会考虑再输入的过程中用count计数,这里就需要注意正负抵消的问题,如果幂数相同的两个项的系数为相反数,这样相加之后会抵消,这是要注意count需要自减,所以不推荐这样的写法,比较麻烦
4.memset函数的简单用法(不全可以自行查找):memset(数组名称,要设置的数,设置的长度);可以参考我的代码来看,很容易懂

解题思路:
1.用double型数组表示多项式,其中p[n]表示幂数为0的项的系数,初始值为0,用count计数,初始值为0
2.可以考虑用memset函数来进行数组元素初始化,它包含在<string.h>中,记得加上
3.两个多项式分别输入,输入第二个多项式的时候将对应系数直接加到第一个多项式上面,可以避免抵消问题
4.计算非零系数项的个数count并输出,然后按照格式输出多项式

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

纳萨斯瓦德

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值