PAT A1009 Product of Polynomials

This time, you are supposed to find A×B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N​1​​ a​N​1​​ ​​ N​2​​ a​N​2​​ ​​ … N​K​​ a​N​K​​ ​​
where K is the number of nonzero terms in the polynomial, N​i​​ and a​N​i​​ ​​ (i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10, 0≤N​K​​ <⋯<N​2​​ <N​1​​ ≤1000.
Output Specification:
For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.
Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 3 3.6 2 6.0 1 1.6

接下来是AC代码:

#include <cstdio>	

struct Poly{
	int exp;  //指数 
	double cof;  //系数 
}poly[1010];//第一个多项式 
//这样不需要用memset进行置零
double ans[2010]={0};  //存放结果 

int main() {
	int n,m,number=0;
	scanf("%d",&n);//第一个多项式中非零项的个数
	for(int i=0;i<n;i++){
		scanf("%d %lf",&poly[i].exp,&poly[i].cof);
	}
	scanf("%d",&m);//第二个多项式中非零项的个数
	for(int i=0;i<m;i++){
		int exp;
		double cof;
		scanf("%d %lf",&exp,&cof);//第二个多项式的指数与项数
		//进行乘法操作 
		for(int j=0;j<n;j++){
			ans[exp+poly[j].exp] += (cof*poly[j].cof);
		} 
	}
	//通过遍历计算非零项数的个数 
	for(int i=0;i<=2010;i++){
		if(ans[i]!=0.0){
			number++;
		}
	}
	//输出 
	printf("%d",number);
	for(int i=2010-1;i>=0;i--){
		if(ans[i]!=0.0){
			printf(" %d %.1lf",i,ans[i]);
		}
	} 
	return 0;
}

解题思路:
先获得第一个多项式的系数,然后在输入第二个系数的时候循环与第一个多项式的系数相乘,并将结果放到ans数组的对应系数上面,最后输出ans数组的非零项
需要注意:
1.答案的系数数组至少要开到2001,因为两个1000幂次的多项式相乘会有2000项
2.没有必要开两个数组存放两个多项式然后等到读完数在进行处理,只需要第二个多项式的系数边读入边处理
3.系数从大到小输出
4.只输出非零项

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

纳萨斯瓦德

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值