HDUOJ1381Crazy Search(STL/map)

Crazy Search

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3632 Accepted Submission(s): 1314

Problem Description
Many people like to solve hard puzzles some of which may lead them to madness. One such puzzle could be finding a hidden prime number in a given text. Such number could be the number of different substrings of a given size that exist in the text. As you soon will discover, you really need the help of a computer and a good algorithm to solve such a puzzle.

Your task is to write a program that given the size, N, of the substring, the number of different characters that may occur in the text, NC, and the text itself, determines the number of different substrings of size N that appear in the text.

As an example, consider N=3, NC=4 and the text “daababac”. The different substrings of size 3 that can be found in this text are: “daa”, “aab”, “aba”, “bab”, “bac”. Therefore, the answer should be 5.

Input
The first line of input consists of two numbers, N and NC, separated by exactly one space. This is followed by the text where the search takes place. You may assume that the maximum number of substrings formed by the possible set of characters does not exceed 16 Millions.

Output
The program should output just an integer corresponding to the number of different substrings of size N found in the given text.
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Sample Input
1

3 4
daababac

Sample Output
5

#include<iostream>
#include<cstring>
#include<map> 
using namespace std;
int main(){
	int t,a,b;
	cin>>t;
	while(t--){
		int k=0;
		string s;
		map<string,int> snum;//创建一个map容器,键位string类型的,值为int型 
		cin>>a>>b>>s;
		for(int i=0;i<=s.length()-a;i++){
			string ss = s.substr(i,a);//切割从i开始,长度为a子串 
			if(snum[ss]==0){//得到一个字符作为下标放入map中,进行判断是否出现过 
				k++;//进行计数,返回字串数量 
				snum[ss]=1;//标记这个下标,下次出现就不进入循环。 
			}
		}
		cout<<k<<endl;
		if(t>1){
			cout<<endl;
		}
	}
	return 0;
}  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值