【38.63%】【hdu 3047】Zjnu Stadium

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3003 Accepted Submission(s): 1160

Problem Description
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.

Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.

Output
For every case:
Output R, represents the number of incorrect request.

Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100

Sample Output
2
Hint

Hint:
(PS: the 5th and 10th requests are incorrect)

Source
2009 Multi-University Training Contest 14 - Host by ZJNU

【题解】

像是
1 2 4
1 3 4
这样的话都是可行的。
只是说列差为4,但没有说要坐在哪一排(而排数是无限的)。
但是如果说 2 3 1则是错的了
因为2和3的相对列差是为0而不是1;
这样想了以后就可以想到用带权并查集来处理;
权值就是两个点的相对距离。儿子的节点的权值表示父亲在自己的顺时针权值远处。
因为是个环所以要取模;
用到了权值向量的方法。讲解可以看我之前的一篇文章。地址在这里;
用的都是类似的方法
http://blog.csdn.net/harlow_cheng/article/details/52737486

//爱上手写输入的我~~~
#include <cstdio>

const int MAXN = 51000;
const int MOD = 300;

int n, m,fade = 0;
int re[MAXN], f[MAXN];

void input(int &r)
{
    char t;
    do { t = getchar(); } while (t <'0' || t>'9');
    r = 0;
    while (t >= '0' && t <= '9') {r = r * 10 + t - '0'; t = getchar();}
}

int ff(int x)
{
    if (f[x] == x)
        return x;
    int olfa = f[x];
    f[x] = ff(f[x]);
    re[x] = (re[x] + re[olfa])%MOD;
    return f[x];
}

int main()
{
    //freopen("F:\\rush.txt", "r", stdin);
    while (~scanf("%d%d", &n, &m))
    {
        fade = 0;
        for (int i = 1; i <= n; i++)
            f[i] = i, re[i] = 0;
        for (int i = 1;i <= m;i++)
        {
            int x, y, z;
            input(x); input(y); input(z); //slower than "scanf" in this scale
            //scanf("%d%d%d", &x, &y, &z);
            z %= MOD;
            int a = ff(x), b = ff(y);
            if (a != b)
            {
                f[a] = b;
                re[a] = (z + re[y] - re[x] + MOD) % MOD;
            }
            else
            {
                int temp = (re[x] - re[y] + MOD) % MOD;
                if (temp != z)
                    fade++;
            }
        }
        printf("%d\n", fade);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值