HDU1010(奇偶剪枝+dfs)

The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

‘X’: a block of wall, which the doggie cannot enter;
‘S’: the start point of the doggie;
‘D’: the Door; or
‘.’: an empty block.

The input is terminated with three 0’s. This test case is not to be processed.
Output
For each test case, print in one line “YES” if the doggie can survive, or “NO” otherwise.
Sample Input
4 4 5
S.X.
…X.
…XD

3 4 5
S.X.
…X.
…D
0 0 0
Sample Output
NO
YES
题意是说要要在特定的t时间到达出口,而不是在t时间内到达出口,所以不适合用bfs,用dfs最好,记得每个路线走过的格子要标记,路线走完后要恢复。
该题直接用Bfs会超时,得结合奇偶剪枝。详见代码

ac代码

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <math.h>
#include <cstdlib>
#include <queue>
#include<iomanip>
using namespace std;
int ji[10][10],N,M,T,v,n;
char p[10][10];
int a, s, d,sum=0;
int s1[4] = { 0,0,1,-1 }, s2[4] = { 1,-1,0,0 };
void dfs(int x, int y, int time)
{
	int q = T - time - (abs(v - x) + abs(n- y));//记距指定时间还剩多少时间减去从改点到出口的最短时间的结果
	if (q < 0 || q % 2)return;//走最短路线都不能赶在指定时间到出口,说明接下来不需要走了,还有q必须是偶数,如果是奇数最多只能走到出口的周围。(可以想象若按最短路线刚好在指定时间到达出口,比如左上角走到右下角,那最短路线就是只能往右或往下(此时是没有阻碍的最短路线))那要走更长的路就要有向上或向左,一个向上必然对应一个向下,同理向左,所以多出来的步数之和肯定为偶数。

		if (p[x][y] == 'D'&&time == T)
			{
				sum = 1;	cout << "YES" << endl; return;
			}
		
	if (time > T)return;
	int xxx, yyy;
	for (int i = 0; i < 4; i++)
	{
		xxx =x + s1[i];
		yyy = y + s2[i];
		
		if (xxx >=0 && yyy >=0 && xxx < N&&yyy < M && !ji[xxx][yyy] && p[xxx][yyy] != 'X'&&!sum)
		{
                  ji[xxx][yyy] = 1;
			dfs(xxx, yyy, time + 1);
			ji[xxx][yyy] = 0;
		}
	}
}
int main()
{
	while (cin >> N >> M >> T)
	{
		sum =0;
		memset(ji, 0, sizeof(ji));
		if (N == 0 && M == 0 && T == 0)
			break;
		for(int i=0;i<N;i++)
			for (int j = 0; j < M; j++)
			{
				cin >> p[i][j];
				if (p[i][j] == 'S')
				{
					a = i; d = j;
				}
				if (p[i][j] == 'D')
				{
					v = i; n = j;
				}
			}ji[a][d] = 1;
		dfs(a,d,0);
		if (!sum)cout << "NO" << endl;
	}
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值