HDU1224(DP,存图+DFS)

Problem Descrption

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number.

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both 1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit.

Output a blank line between two cases.

Sample Input

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

Sample Output

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1

问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1224

问题分析:

首先考虑如何存图,把各个顶点所连接的城市记录下来,利用一个二维数组pre[i][a]记录城市i连接的城市,用数组a[i]表示i城市

连接的城市数。存完图后,考虑遍历每一个城市所有的连接点,本来打算用循环但是想想很难写,然后想到了用DFS遍历每一种情况

部分情况待改善的代码:

#include<iostream>
#include<cstring>
using namespace std;
int pre[105][105], a[105] = { 0 }, p[105] = {0},kx[105],xe[105];
int n, b[105], m, tx,min1,max1=0,u=0;
void dfs(int x, int in,int step)//x为所在城市,in为到达该城市所有的趣味值,step为到该城市所用步数
{
	if (x == n + 1)//到达终点,更新路径和趣味值in
	{
		if (in > max1)
		{
			max1 = in;
			min1 = step;
			for (int i = 0; i < step; i++)kx[i] = xe[i];
		}
	}
	for (int i = 1; i <= a[x]; i++)//a[x]为该城市所连接的城市数,遍历所有连接城市
	{
		tx = pre[x][i];
		if (tx > n+1)continue;//判断是否越界
		if (p[tx] == 0)
		{
			xe[step] = x;
			p[tx] = 1;//标记已访问
			dfs(tx, in + b[tx],step+1);
			p[tx] = 0;
		}
		
	}

}
int main()
{
	int t,yy=1;
	cin >> t;
	while (t--)
	{
		cin >> n;
		max1 = 0;
		memset(a,0,sizeof(a));
		memset(xe, 0, sizeof(xe));
		memset(kx, 0, sizeof(kx));
		memset(p, 0, sizeof(p));
		memset(b,0,sizeof(b));
		for (int i = 1; i <=n; i++)cin >> b[i];
		cin >> m;
		int p1, p2,k;
		for (int i = 0; i < m; i++)//每读入一条路,就记录城市p1有一条路连接p2
		{
			cin >> p1 >> p2;
			a[p1]++;//记录城市p1的路数
			pre[p1][a[p1]] = p2;//p1有一条路通往p2
		}
		//for (int i = 1; i <=n; i++)
		//{
			//for (int j = 1; j <=a[i]; j++)
				//cout << pre[i][j] << " ";
			//cout << endl;
		//}
		dfs(1, 0, 0);
		//cout << max1<< endl;
		printf("CASE %d#\npoints : %d\ncircuit : ", yy++, max1);
		for (int i = 0; i < min1; i++)
		{
			cout << kx[i] << "->";
		}
		if(t>=1)cout << "1\n\n";
		else cout <<"1"<<endl;
		
		
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值