POJ3278(BFS入门)

Problem Descrption

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

问题链接:http://poj.org/problem?id=3278

问题分析:搜索类问题,首先想到DFS和BFS两种,像这种很大的,如果用深搜很容易超时,所以明显是BFS,一开始写

为了记录步数使用了结构数组,然而这样会ML,这也给我提醒,以结构类型的队列可能内存较大,后来利用及数组记录父子节点的方式解决,可以建立数组ed[tx]=t,即记录tx的父节点为t,最后再回溯即可;

AC代码:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int n, k;
int vis[100005];
int ed[100005];
void bfs()
{
	queue<int>q;
	q.push(n);
	vis[n];
	while (!q.empty())
	{
		int t = q.front();
		if (t == k)
		{
			return;
		}
		q.pop();
		int tx;
		for (int i = 0; i < 3; i++)
		{
			if (i == 0) { tx = t + 1; }
			if (i == 1) { tx = t * 2; }
			if (i == 2) { tx = t - 1; }
			if (tx > 100000 || tx < 0 || vis[tx])continue;
			q.push(tx);
			ed[tx] = t;
			vis[tx]=1;
		}
	}
}
int main()
{
	while (cin >> n >> k)
	{
		memset(vis, 0, sizeof(vis));
		bfs();
		int t=k,step=0;
		while (t!=n)
		{
			t = ed[t];
			step++;
		}
		cout << step << endl;
	}
}

因使用结构队列而ML的代码:

#include<iostream>
#include<queue>
#include<cstring>
using namespace std;
int n, k,min1=999999;
int vis[100005];
struct way
{
	int x;
	int step;
};
void bfs()
{
	queue<way>q;
	struct way a;
	a.x = n, a.step = 0;
	q.push(a);
	vis[a.x];
	while (!q.empty())
	{
		struct way t = q.front();
		if (t.x == k)
		{
			if (t.step < min1)min1 = t.step;
			return;
		}
		q.pop();
		struct way tx;
		for (int i = 0; i < 3; i++)
		{
			if (i == 0) { tx.x = t.x + 1; tx.step =t.step+1; }
			if (i == 1) { tx.x = t.x * 2; tx.step =t.step+1; }
			if (i == 2) { tx.x = t.x - 1; tx.step = t.step + 1; }
			if (tx.x > 100000 || tx.x < 0 || vis[tx.x])continue;
			q.push(tx);
			vis[tx.x];
		}
	}
}
int main()
{
	while (cin >> n >> k)
	{
		memset(vis, 0, sizeof(vis));
		min1 = 9999999;
		bfs();
		cout << min1 << endl;
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值