HDU1505

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0

问题链接:

Bob is a strategy game programming specialist. In his new city building game the gaming environment is as follows: a city is built up by areas, in which there are streets, trees,factories and buildings. There is still some space in the area that is unoccupied. The strategic task of his game is to win as much rent money from these free spaces. To win rent money you must erect buildings, that can only be rectangular, as long and wide as you can. Bob is trying to find a way to build the biggest possible building in each area. But he comes across some problems – he is not allowed to destroy already existing buildings, trees, factories and streets in the area he is building in.

Each area has its width and length. The area is divided into a grid of equal square units.The rent paid for each unit on which you're building stands is 3$.

Your task is to help Bob solve this problem. The whole city is divided into K areas. Each one of the areas is rectangular and has a different grid size with its own length M and width N.The existing occupied units are marked with the symbol R. The unoccupied units are marked with the symbol F.

Input

The first line of the input contains an integer K – determining the number of datasets. Next lines contain the area descriptions. One description is defined in the following way: The first line contains two integers-area length M<=1000 and width N<=1000, separated by a blank space. The next M lines contain N symbols that mark the reserved or free grid units,separated by a blank space. The symbols used are:

R – reserved unit

F – free unit

In the end of each area description there is a separating line.

Output

For each data set in the input print on a separate line, on the standard output, the integer that represents the profit obtained by erecting the largest building in the area encoded by the data set.

Sample Input

2
5 6
R F F F F F
F F F F F F
R R R F F F
F F F F F F
F F F F F F

5 5
R R R R R
R R R R R
R R R R R
R R R R R
R R R R R

Sample Output

45
0

问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1505

问题分析:

思路: 1.针对于dp数组中代表的每一个点,我们为其设置它的高度h。
  
 当这个点是障碍时,我们把它的高度设置为0,否则它的高度是垂直方向的上一个点加1。
2.我们设法求出该点向左和向右能够延伸的最大距离。然后用right - left + 1就等于边的长度。
3.我们用高乘以边得到面积,通过判断后找到最大的面积,就可以得到答案了。

如何表示高度: 在输入的时候就行判断,然后对dp数组进行初始化。如果是F,则h[i][j] = h[i-1][j] + 1,否则h[i][j] =
0。
如何表示宽度: 我们按行进行遍历,对于第i行的点,分别为它们设置下标对应的l,r数组进行表示left,right。
以找左边最大延伸距离为例:当向左边延伸的时候,我们判断该点的左边的点的高度,如果左边点
的高度大于等于该点的高度,说明这个点是可以延伸到的,所以我们继续向该点的下一个点进行延 
伸。
 for(int j = 1; j <= N; j++){
                while(h[i][l[j]-1] >= h[i][j]){
                    l[j] = l[l[j]-1];
                }
            }
--------------------- 
作者:海棠花开 
来源:CSDN 
原文:https://blog.csdn.net/smallhc/article/details/78713260 
版权声明:本文为博主原创文章,转载请附上博文链接!

#include<iostream>
#include<cstring>
#include<cmath>
#include<stdio.h>
using namespace std;
int h[1005][1005],l[1005],r[1005];
int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		int n, m,max;
		char s;
		cin >> n >> m;
		memset(h, 0, sizeof(h));
		memset(l, 0, sizeof(l));
		memset(r, 0, sizeof(r));
		max = 0;
		int sum;
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <=m; j++) 
			{ scanf("%s", &s); if (s == 'F')h[i][j] = h[i - 1][j] + 1; else h[i][j] = 0; }
		for (int i = 1; i <= n; i++)
		{
			for (int i = 1; i <= m; i++)l[i] = r[i] = i;
			for (int a = 1; a <= m; a++)
			{
				for (int b= a + 1; b <= m; b++)
				{
					if (h[i][b] >= h[i][a])
						r[a] = b;
					else break;
				}
				for (int b = a - 1; b >= 1; b--)
				{
					if (h[i][b] >= h[i][a])
						l[a] = b;
					else break;
				}
				sum = h[i][a] * (r[a] - l[a]+1)*3;
				if (max < sum)max = sum;
			}
		}
		printf("%d\n", max);
	}
}

AC代码:

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值