HDU-1159 Common Subsequence【C++练习题】【dp+动态规划】

Common Subsequence
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51302 Accepted Submission(s): 23616

Problem Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, …, xm> another sequence Z = <z1, z2, …, zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, …, ik> of indices of X such that for all j = 1,2,…,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc abfcab
programming contest
abcd mnp

Sample Output

4
2
0

Source

Southeastern Europe 2003

Recommend

Ignatius

问题简述:
       其实一开始看例子有点没搞懂,英语可能不是很好。可能大概意思就是找2串字符中的共有的最大序列。就比如abcfbc abfcab 两个的最大序列就是abcb,就是两个字符串中间的字母可以跳过,但是一定是从左到右的顺序。(我是新手)

做题思路:
       dp[i][j] (i表示a的长度,j表示b的长度,dp[i][j]就是检索到第i个a串中的字符和第j个b串的字符中最大的公共子序列吧)
       if (a[i - 1] == b[j - 1])
       dp[i][j] = dp[i - 1][j - 1] + 1;
       (这一串代码的意思就如果a的字符串跟b的字符串相等,那么它就是他们俩前一个字符串都往后一位得到的结果,所以是前一个两个字符串a b的最大公共子序列+1)
       else
       dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
       (这一串代码的意思就是如果这两个不相等那它们最大子序列是a的前一位或者是b的前一位时a b的最大公共序列)
贴上代码↓↓↓

#include <iostream>
#include <algorithm>
using namespace std;

int dp[1005][1005];
void main()
{
	memset(dp, 0, sizeof(dp));
	char a[1005], b[1005];
	int lena, lenb;
	while (cin >> a >> b)
	{
		lena = strlen(a);
		lenb = strlen(b);
		for (int i = 1; i <= lena; i++)//从i=1 j=1开始
		{
			for (int j = 1; j <= lenb; j++)
			{
				if (a[i - 1] == b[j - 1])
					dp[i][j] = dp[i - 1][j - 1] + 1;
				else
					dp[i][j] = max(dp[i - 1][j], dp[i][j - 1]);
			}
		}
		cout << dp[lena][lenb]<<endl;
	}
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值