关于springmvc项目一加入validation-api包就报错的解决方法

前言

  • springmvc要进行数据校验,通常是利用hibernate中的校验框架validation,使用validation需要在项目中加入三个jar包:
  • hibernate-validator-4.3.0.Final.jar
  • jboss-logging-3.1.0.cr2.jar
  • validation-api-1.0.0.GA.jar
  • 这是学习ssm框架时老师说要导入的三个jar包

问题

  • 在你把jar包加入你的项目的lib目录的时候,如果这时候tomcat服务器是启动的,你可以会发现,直接就报错了,原因是你导入了validation-api这个jar包。

解决方法

  • 换jar包!
  • hibernate-validator-6.0.7.Final.jar
  • jboss-logging-3.4.0.Final.jar
  • validation-api-2.0.1.Final.jar
  • 这是三个较新的jar包,但还不能解决问题,还需要加入关键的一个jar包:
  • classmate-1.5.0.jar
  • 把这四个jar加入之后,你会发现,服务器不会报错,页面也能正常访问了。

切记

classmate-1.0.0.jar需要与高版本的validator包搭配,因此我下载了最新的 hibernate-validator-6.0.7.Final.jar

友情链接

hibernate-validator-6.0.7.Final.jar

jboss-logging-3.4.0.Final.jar

validation-api-2.0.1.Final.jar

classmate-1.5.0.jar

已标记关键词 清除标记
相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页