HDU-1049 Climbing Worm

Problem Description

An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We’ll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we’ll assume the worm makes it out.

Input

There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.

Output

Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.

Sample Input

10 2 1
20 3 1
0 0 0

Sample Output

17
19

问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1049

问题解析:
题目为一只虫子在一个深n的井底向上爬,一分钟可以往上爬u,但是会在接下来的一分钟向下滑d。用while实现多次爬上多次掉下的过程,需注意的是可能爬上去之后就到井外了就不会再掉下,所以应该在爬上和下滑的中间加一个判断是否已经到达井外跳出循环的语句。

AC通过的c++程序如下:

#include<iostream>
using namespace std;
int main()
{
	int n,u,d,t;
	while(cin>>n>>u>>d)
	{
		if(n+u+d==0) break;
		t=0;
		int s=0;
		while(s<=n)
		{	s+=u;
			t++;
			if (s>=n) break;
			s-=d;
			t++;
		}
		cout<<t<<endl;
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值