PAT 1004 Counting Leaves (30分)

原题

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1

题意

题意
给出一棵树,要求输出树每一层的叶子节点有多少
输入
先输入n和m
后接m行
每一行第一个数为一个ID,即两个数字,如01,02,99
第二个数为k,即代表第一个输入的父亲ID有k个儿子,后接k个儿子ID
输出
输出每一层的叶子节点数


思路

一开始我就把题目就理解错了,题目要求是计算树每一层的叶子节点(叶子节点即没有儿子节点的节点)
所以应该很容易想到bfs,遍历每一层并且计算叶子节点数
用并查集的思路求根节点

自己写的代码

#include<iostream>
#include<vector>
#include<queue>
using namespace std;
#define N 110
#define PII pair<int,int>
int idx,n,m,fa[N],ans[N];//fa数组用以查询根节点
vector<int>v[N];
void bfs(){
    queue<PII>q;
    for(int i=1;i<=n;i++){
        if(fa[i]==i){//如果父亲是自己,那么这个点就是根节点
            q.push({i,0});
            break;//不用继续找了
        }
    }
    while(q.size()){
        PII now=q.front();
        q.pop();
        int des=now.first,dep=now.second;
        idx=max(idx,dep);
        if(v[des].size()==0)
        ans[dep]++;
        for(int item:v[des]){
            q.push({item,dep+1});
        }
    }
}
int main(){
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)fa[i]=i;
    for(int i=0;i<m;i++){//注意是m,不要写错了输入
        int s,er,k;//s作为父节点,er作为子节点,k就是有几个儿子节点
        cin>>s>>k;
        for(int j=0;j<k;j++){
            cin>>er;
            v[s].push_back(er);//er是s的儿子
            fa[er]=s;//er的父亲是s
        }
    }
    bfs();//开始广搜
    for(int i=0;i<=idx;i++){
        cout<<ans[i];
        if(i!=idx)cout<<" ";
    }
    return 0;
}

思路改进

其实题目暗示根节点就是1
本题也可以用dfs,基本实现过程都一样

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值