Oil Deposits

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46075 Accepted Submission(s): 26550

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either '*', representing the absence of oil, or‘@’, representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output
0
1
2
2

问题链接:Oil Deposits.

问题简述:

探测石油矿,将所探测地域分为m行n列的小方块。如果该小方块有石油则标记为“@”,否则标记为“*”。现已知:如果两块小方块有石油,一块位于以另一块为中心的九方格内,则表明这两块位于同一块油田。问:所探测地域有多少块油田?

问题分析:

问题首先要求我们找到有石油的方块,再将连着这块地方的所有有石油的方块找出。可以利用深度优先搜索。

程序说明:

dev[8][2]数组保存着深度优先搜索的方向,8个方向。
所有找到的油田更换标记,防止重复寻找。
找到了有石油的地方再顺着往下找,否则寻找下一个小方块。

AC通过的C语言程序如下:

#include<iostream>

using namespace std;

int dev[8][2] = { -1,-1,-1,0,-1,1,0,-1,0,1,1,-1,1,0,1,1 };
void find(char* c, const int a, const int b, int i, int j);

int main()
{
	int a, b;
	while (cin >> a >> b)
	{
		if (a == 0 && b == 0)return 0;
		char c[a][b];
		int ans = 0;
		for (int i = 0; i<a; i++)
		{
			for (int j = 0; j<b; j++)
			{
				cin >> c[i][j];
			}
		}
		
		for (int i = 0; i<a; i++)
		{
			for (int j = 0; j<b; j++)
			{
				if (c[i][j] == '@')
				{
					ans++;
					find((char*)c, a, b, i, j);
				}
			}
		}
		cout << ans << endl;
	}
	return 0;
}

void find(char *c, const int a, const int b, int i, int j)
{
	*(c+i*b+j) = '*';
	for (int k = 0; k <8; k++)
	{
		if (*(c+(i+dev[k][0])*b+(j+dev[k][1])) == '@' && i+dev[k][0] >= 0
			&& i+dev[k][0]<a&&j+dev[k][1] >= 0
			&& j+dev[k][1]<b)
			find(c, a, b, i+dev[k][0], j+dev[k][1]);

	}
	return;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值