poj3279(第一天H题)

题目:Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2… M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1… M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

解:因为下面一行每次只能影响上一行的一块,要全部翻好则第一行确定时,就已经确定翻多少
只要搜索第一行所有的情况就可以

只有翻与不翻类似二进制0和1,有2的n次方种情况,一直求余二则为求二进制的方法。

代码:

#include<iostream>
using namespace std;
int a[20][20];
int b[20][20];
int c[20][20];
int d[20][20];
int account;
int pint;
int lock;
void remark(int x,int y)
{
	pint = account;
	for (int i = 1; i <= x; i++)
	{
		for (int j = 1; j <= y; j++)
		{
			d[i][j] = c[i][j];
		}
	}
}
void turn(int x, int y)
{
	c[x][y] = 1;
	account++;
	b[x][y] = 1 - b[x][y];
	b[x - 1][y] = 1 - b[x - 1][y];
	b[x + 1][y] = 1 - b[x + 1][y];
	b[x][y - 1] = 1 - b[x][y - 1];
	b[x][y + 1] = 1 - b[x][y + 1];
}
int main()
{
	int m, n;
	while (cin >> m >> n)
	{
		for (int i = 1; i <= m; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				cin >> a[i][j];
			}
		}
		int t = 1 << n;//第一行的情况种类数,向左位运算类似于乘2(计算每种第一行的情况所需次数)
		for (int i = 0; i < t; i++)
		{
			memset(c, 0, sizeof(c));
			for (int i = 1; i <= m; i++)
			{
				for (int j = 1; j <= n; j++)
				{
					b[i][j] = a[i][j];
				}
			}
			int pm = t;
			account = 0;
			pint = 99999;
			for (int i = 1; i <= pm; i++)    //翻转第一行
			{
				if (pm % 2 == 1)
				{
					turn(1, i);
				}
				pm /= 2;
			}
			for (int i = 2; i <= m; i++)
			{
				for (int j = 1; j <= n; j++)
				{
					if (b[i - 1][j] == 1)
					{
						turn(i, j);
					}
				}
			}
			for (int j = 1; j <= n; j++)
			{
				if (b[m][j] == 1)
				{
					break;
				}
				if (j == n)
				{
					lock = 1;  //只要成功一次不会是not impossible
					if (account < pint)
					{
						remark(m, n);
					}
				}
			}
		}
		if (lock == 0)
		{
			cout << "IMPOSSIBLE" << endl;
			return 0;
		}
		for (int i = 1; i <= m; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				if (j != 1)
				{
					cout << " ";
				}
				cout << d[i][j];
				if (j == n)
				{
					cout << endl;
				}
			}
		}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
目标检测(Object Detection)是计算机视觉领域的一个核心问,其主要任务是找出图像中所有感兴趣的目标(物体),并确定它们的类别和位置。以下是对目标检测的详细阐述: 一、基本概念 目标检测的任务是解决“在哪里?是什么?”的问,即定位出图像中目标的位置并识别出目标的类别。由于各类物体具有不同的外观、形状和姿态,加上成像时光照、遮挡等因素的干扰,目标检测一直是计算机视觉领域最具挑战性的任务之一。 二、核心问 目标检测涉及以下几个核心问: 分类问:判断图像中的目标属于哪个类别。 定位问:确定目标在图像中的具体位置。 大小问:目标可能具有不同的大小。 形状问:目标可能具有不同的形状。 三、算法分类 基于深度学习的目标检测算法主要分为两大类: Two-stage算法:先进行区域生成(Region Proposal),生成有可能包含待检物体的预选框(Region Proposal),再通过卷积神经网络进行样本分类。常见的Two-stage算法包括R-CNN、Fast R-CNN、Faster R-CNN等。 One-stage算法:不用生成区域提议,直接在网络中提取特征来预测物体分类和位置。常见的One-stage算法包括YOLO系列(YOLOv1、YOLOv2、YOLOv3、YOLOv4、YOLOv5等)、SSD和RetinaNet等。 四、算法原理 以YOLO系列为例,YOLO将目标检测视为回归问,将输入图像一次性划分为多个区域,直接在输出层预测边界框和类别概率。YOLO采用卷积网络来提取特征,使用全连接层来得到预测值。其网络结构通常包含多个卷积层和全连接层,通过卷积层提取图像特征,通过全连接层输出预测结果。 五、应用领域 目标检测技术已经广泛应用于各个领域,为人们的生活带来了极大的便利。以下是一些主要的应用领域: 安全监控:在商场、银行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值