POJ 2486:Apple Tree(树形DP)

Apple Tree
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7789 Accepted: 2606
Description

Wshxzt is a lovely girl. She likes apple very much. One day HX takes her to an apple tree. There are N nodes in the tree. Each node has an amount of apples. Wshxzt starts her happy trip at one node. She can eat up all the apples in the nodes she reaches. HX is a kind guy. He knows that eating too many can make the lovely girl become fat. So he doesn’t allow Wshxzt to go more than K steps in the tree. It costs one step when she goes from one node to another adjacent node. Wshxzt likes apple very much. So she wants to eat as many as she can. Can you tell how many apples she can eat in at most K steps.
Input

There are several test cases in the input
Each test case contains three parts.
The first part is two numbers N K, whose meanings we have talked about just now. We denote the nodes by 1 2 … N. Since it is a tree, each node can reach any other in only one route. (1<=N<=100, 0<=K<=200)
The second part contains N integers (All integers are nonnegative and not bigger than 1000). The ith number is the amount of apples in Node i.
The third part contains N-1 line. There are two numbers A,B in each line, meaning that Node A and Node B are adjacent.
Input will be ended by the end of file.

Note: Wshxzt starts at Node 1.
Output

For each test case, output the maximal numbers of apples Wshxzt can eat at a line.
Sample Input

2 1
0 11
1 2
3 2
0 1 2
1 2
1 3
Sample Output

11
2


题意:一颗树,n个点(1-n),n-1条边,每个点上有一个权值,求从1出发,走K步,最多能遍历到的权值

解题思路:dp[i][j][0]表示在i节点,有j步可以走,最后返回i节点的情况下可以吃多少苹果,dp[i][j][1]表示在i节点,有j步可以走,最后不返回i节点的情况下可以吃多少苹果。先dfs到叶子节点,显然0步就可以吃到苹果,然后回溯,对父亲节点来说,所有儿子按顺序跑一遍背包,背包容量从0到K,然后对于每个儿子节点要么返回要么不返回,区别处理一下即可。
dp[root][j][0] = MAX (dp[root][j][0] , dp[root][j-k][0] + dp[son][k-2][0]);//从root出发,要回到root,需要多走两步root-j,j-root,分配给j子树k步,其他子树j-k步,都返回

dp[root][j]][1] = MAX( dp[root][j][1] , dp[root][j-k][0] + dp[son][k-1][1]) ;//先遍历root的其他子树,回到root,遍历j子树,在当前子树j不返回,多走一步

dp[root][j][1] = MAX (dp[root][j][1] , dp[root][j-k][1] + dp[son][k-2][0]);//不回到root(去root的其他子树),在j子树返回,同样有多出两步

#include<iostream>
#include<algorithm>
#include <stdio.h>
#include <string.h>
using namespace std;
const int maxn=205;
struct node{
    int u;
    int v;
    int w;
    int next;
}tree[maxn<<1];
int head[maxn],dp[maxn][maxn<<1][2],val[maxn];
int len,n,k;
void addedge(int u,int v){
    tree[len].u=u;
    tree[len].v=v;
    tree[len].next = head[u];
    head[u] = len++;
}
void dfs(int x, int fa, int k){
	for(int i=head[x];i!=-1;i=tree[i].next){
		int to=tree[i].v;
		if(to==fa)
            continue;
		dfs(to,x,k);
		for(int j=k;j>= 0;j--){
			for(int s=1;s<= j;s++){
				if(s>=2){
					dp[x][j][0]=max(dp[x][j][0],dp[x][j-s][0]+dp[to][s-2][0]);//从x出发最后返回,需多走两步
				}
				dp[x][j][1]=max(dp[x][j][1],dp[x][j-s][0]+dp[to][s-1][1]);//先遍历x的其他子树,回到x,遍历j子树,在当前子树不返回,多走一步
				if(s >= 2){
					dp[x][j][1]=max(dp[x][j][1],dp[x][j-s][1]+dp[to][s-2][0]);//不回到x,在j子树返回,同样多出两步
				}
			}
		}
	}
}
int main(){
	int n, k;
	int a,b;
	while(scanf("%d %d", &n, &k) != EOF){
		memset(dp,0,sizeof(dp));
        memset(head,-1,sizeof(head));
        for(int i=1;i<=n;i++){
            scanf("%d",&val[i]);
            for(int j=0;j<=k;j++)
                dp[i][j][0] = dp[i][j][1] = val[i];
        }
        len = 0;
        for(int i=1; i<n; i++){
            scanf("%d%d",&a,&b);
            addedge(a,b);
            addedge(b,a);
        }
        dfs(1, 0, k);
		printf("%d\n", max(dp[1][k][0], dp[1][k][1]));
	}
	return 0;
}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值