HDU - 3555 Bomb(数位dp)

The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3
1
50
500
Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.


题意:求0 到n的数中有多少个数字是含有‘49’的!

解题思路:用数位dp跑一下0到n的不含有‘49’的,然后n减去就行了,具体思路见代码注释。
dp[pos][sta]表示当前第pos位,前一位是否是4的状态,这里sta只需要去0和1两种状态就可以了,不是4的情况可视为同种,不会影响计数。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
ll dp[20][2];
//dp[pos][sta]表示当前第pos位,前一位是否是4的状态,这里sta只需要去0和1两种状态就可以了,不是4的情况可视为同种,不会影响计数。
int a[20];
ll dfs(int pos,int pre,int sta,int limit){
    if(pos==-1)//所有数枚举完了,当前数数字肯定满足条件,直接返回1
        return 1;
    if(!limit && dp[pos][sta]!=-1)//记忆化
        return dp[pos][sta];
    int up=limit?a[pos]:9;
    ll tmp=0;
    for(int i=0;i<=up;i++){
        if(pre==4&&i==9)//pre是该数字的前一位,出现49就直接跳过。
            continue;//保证枚举正确性
        tmp+=dfs(pos-1,i,i==4,limit&&i==a[pos]);//
    }
    if(!limit)
        dp[pos][sta]=tmp;
    return tmp;
}
ll solve(ll t)
{
    int len=0;
    ll n=t;
    while(n)
    {
        a[len++]=n%10;
        n/=10;
    }
    return t+1-dfs(len-1,-1,0,1);
}
int main()
{
    int T;
    ll n;
    memset(dp,-1,sizeof dp);//放在外面会优化一点时间
    scanf("%d",&T);
    while(T--){
        scanf("%lld",&n);
        printf("%lld\n",solve(n));
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值