第二题

George and Accommodation

Time limit 1000 ms
Memory limit 262144 kB

Problem Description

George has recently entered the BSUCP (Berland State University for Cool Programmers). George has a friend Alex who has also entered the university. Now they are moving into a dormitory.
George and Alex want to live in the same room. The dormitory has n rooms in total. At the moment the i-th room has pi people living in it and the room can accommodate qi people in total (pi ≤ qi). Your task is to count how many rooms has free place for both George and Alex.

Input

The first line contains a single integer n (1 ≤ n ≤ 100) — the number of rooms.
The i-th of the next n lines contains two integers pi and qi (0 ≤ pi ≤ qi ≤ 100) — the number of people who already live in the i-th room and the room’s capacity.

#Output

Print a single integer — the number of rooms where George and Alex can move in.

Sample Input

3
1 10
0 10
10 10

##Sample Output

2

第二题

问题链接:https://vjudge.net/problem/CodeForces-467A

问题简述:

有n间房间,一间房间已有p(i)人,总共能容纳q(i)人,问能满足两人同住一间房的有几间房间

问题分析:

首先输入n确定房数,通过循环输入n次p(i)和q(i),利用逻辑表达式p(i) <= q(i) - 2确定此房是否满足并记录,最后输入记录数即可

程序说明:

用sanf输入n,通过for循环输入p(i)和q(i),并通过sum的自增来记录合适房间数,最后输出sum即可

AC通过的C语言程序如下:

#include <iostream>

int main()
{
	int n, pi, qi;
	int sum=0;
	scanf("%d", &n);
	for (int i = 0;i < n;i++)
	{
		scanf("%d%d", &pi, &qi);
		if (pi <= qi - 2)
		{
			sum++;
		}
	}
	printf("%d\n", sum);
	return 0;

    
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值