1.22 B

B - 2

Time limit 2000 ms
Memory limit 262144 kB

Problem Description

Shapur was an extremely gifted student. He was great at everything including Combinatorics, Algebra, Number Theory, Geometry, Calculus, etc. He was not only smart but extraordinarily fast! He could manage to sum 1018 numbers in a single second.

One day in 230 AD Shapur was trying to find out if any one can possibly do calculations faster than him. As a result he made a very great contest and asked every one to come and take part.

In his contest he gave the contestants many different pairs of numbers. Each number is made from digits 0 or 1. The contestants should write a new number corresponding to the given pair of numbers. The rule is simple: The i-th digit of the answer is 1 if and only if the i-th digit of the two given numbers differ. In the other case the i-th digit of the answer is 0.

Shapur made many numbers and first tried his own speed. He saw that he can perform these operations on numbers of length ∞ (length of a number is number of digits in it) in a glance! He always gives correct answers so he expects the contestants to give correct answers, too. He is a good fellow so he won’t give anyone very big numbers and he always gives one person numbers of same length.

Now you are going to take part in Shapur’s contest. See if you are faster and more accurate.

Input

There are two lines in each input. Each of them contains a single number. It is guaranteed that the numbers are made from 0 and 1 only and that their length is same. The numbers may start with 0. The length of each number doesn’t exceed 100.

Output

Write one line — the corresponding answer. Do not omit the leading 0s.

Sample Input

1010100
0100101

000
111

1110
1010

01110
01100

Sample Output

1110001

111

0100

00010

问题链接:B - 2
问题简述:

输入两组数(长度一样),进行异或运算

问题分析:

用string存放数,通过对每个数位进行if判断,一位一位输出

程序说明:

没啥好说的。。。

AC通过的C语言程序如下:
#include <iostream>
using namespace std;
#include<string>

int main()
{
	string a;
	string b;
	cin >> a;
	cin >> b;
	int length = a.length();
	for (int i = 0;i < length;i++)
	{
		if ((a[i] == '0') && (b[i] == '0'))
		{
			cout << 0;
		}
		if ((a[i] == '1') && (b[i] == '1'))
		{
			cout << 0;
		}
		if ((a[i] == '0') && (b[i] == '1'))
		{
			cout << 1;
		}
		if ((a[i] == '1') && (b[i] == '0'))
		{
			cout << 1;
		}
	}
	

    
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值