1.18 C

C - 3

Time limit 2000 ms
Memory limit 262144 kB

Problem Description

Kefa decided to make some money doing business on the Internet for exactly n days. He knows that on the i-th day (1 ≤ i ≤ n) he makes ai money. Kefa loves progress, that’s why he wants to know the length of the maximum non-decreasing subsegment in sequence ai. Let us remind you that the subsegment of the sequence is its continuous fragment. A subsegment of numbers is called non-decreasing if all numbers in it follow in the non-decreasing order.

Help Kefa cope with this task!

Input

The first line contains integer n (1 ≤ n ≤ 105).

The second line contains n integers a1,  a2,  …,  an (1 ≤ ai ≤ 109).

Output

Print a single integer — the length of the maximum non-decreasing subsegment of sequence a.

Sample Input

6
2 2 1 3 4 1

3
2 2 9

Sample Output

3

3

问题链接:C - 3
问题简述:

输入n,随后输入n个数
求出最大不变小的连续序列的长度是多长

问题分析:

我们来看sample input
6
2 2 1 3 4 1
sample output
3

2 2 1和1 3 4都可以作为正解

程序说明:

注意存下暂时的最大值即可

AC通过的C语言程序如下:
#include<iostream>
using namespace std;
#include<algorithm>

 int main()
 {
	 int n;
	 int sum = 1;
	 int resum = 1;
	 cin >> n;
	 int a[200000];
	 for(int i=1;i<=n;i++)
	 {
		 cin >> a[i];
	 }
	 for (int i = 1;i < n;i++)
	 {
		 if (a[i] <= a[i + 1])
		 {
			 resum++;
		 }
		 else
		 {resum = 1; }
		 sum= max(sum,resum);
	 }
	 cout << sum;
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值