1月21号acm寒假训练第八题

Time limit1000 msMemory limit65536 kBOSLinuxSource

problem description

定义一个二维数组:

int maze[5][5] = {

0, 1, 0, 0, 0,

0, 1, 0, 1, 0,

0, 0, 0, 0, 0,

0, 1, 1, 1, 0,

0, 0, 0, 1, 0,

};

它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。

Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)

问题链接:https://vjudge.net/contest/279622#problem/H

问题描述:定义一个5*5的数组,用1代表墙壁,用0代表可行走通道,将最短路径的坐标一一列举出来。

问题分析:这题涉及到DFS以及BFS,要慢慢分析问题的内涵。

程序说明:定义两个二维数组,一个用来充当迷宫,一个用来记录是否查询过。用dis[4][2]来表示方向。

c++程序如下:

#include<iostream>
using namespace std;
const int QSize=50;
int a[5][5];
int dis[4][2]={{-1,0},{1,0},{0,-1},{0,1}};
struct Node
{
	int x,y,pre;
}queue[QSize];
int front=0;
int rear=0;
int visit[5][5];
void bfs(int beginX,int beginY,int endX,int endY)
{
	queue[0].x=beginX,queue[0].y=beginY,queue[0].pre=-1;
	rear=rear+1;
	visit[beginX][beginY]=1;
	while(front<rear)
	{
		for(int i=0;i<4;i++)
		{
			int newx=queue[front].x+dis[i][0];
			int newy=queue[front].y+dis[i][1];
			if(newx<0||newx>5||newy<0||newy>5||a[newx][newy]==1||visit[newx][newy]==1)
				continue;
			queue[rear].x=newx;
			queue[rear].y=newy;
			queue[rear].pre=front;
			rear++;
			visit[newx][newy]=1;
			if(newx==endX&&newy==endY)
			{
				return;
			}
		}
		front++;
	}
}
 
void print(Node now)
{
	if(now.pre==-1)
		cout<<"("<<now.x<<", "<<now.y<<")"<<endl;
	else
	{
		print(queue[now.pre]);
		cout<<"("<<now.x<<", "<<now.y<<")"<<endl;
	}
}
 
int main()
{   
   for(int i=0;i<5;i++)
   {
	   for(int j=0;j<5;j++)
	   {
		    cin>>a[i][j];
	   }	  
   }
   bfs(0,0,4,4);
   print(queue[rear-1]);
   return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值