S - Counterfeit Dollar(POJ 1013)

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A~L. Information on a weighing will be given by two strings of letters and then one of the words ”up“, ”down’’, or “even’’. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input
1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 
Sample Output
K is the counterfeit coin and it is light. 
题解

题意:

  • 共12枚硬币,代号为A~L,其中仅有1枚是假币,假币可能较轻,也可能较重
  • 利用天平称量3次,每次两侧放置相同数量的硬币,但不一定每次相同。
  • 根据input,找出假币的代号,并确定是轻还是重

思路:

  • 关键的几点:假币只有一枚,假币相对真币是轻是重不确定,每次两边放相同数量硬币,称量三次必定找到假币。
  • 天平的三种状态:even:两边的硬币都是真的:down/up:假币在其中
  • 假币要么只出现在重的一边,要么只出现在轻的一边,而对于某一真币则都有可能
  • 所以,给每一枚硬币加一个标记,初始为0,若出现在平衡的一边,则记为10(足够大即可),之后不再判断,若在重的一边,则加一,轻的减一。最后在标记不为10的硬币中找绝对值最大的,记为假币,标记的正负判断轻重。
  • 理由是:只要天平不平衡,就一定有假币,当前的硬币的标记就会向着正或负改变,改变的次数为不平衡次数,假币始终往一个方向变,没有其他硬币的标记值绝对值会大于假币的,题目说明一定能找到假币,所以没有绝对值与之相等的硬币。
Code
#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;

struct node
{
    char ch1[7];//左边
    char ch2[7];//右边
    char sign[5];//天平状态
}row[4];

int book[77];

int main()
{
    int n, j, len, p, k, i, max;
    char ch[10];
    cin >> n;
    while (n--)
    {
        for(j = 65; j < 77; j++)            
            book[j] = 0;
        for(j = 0; j < 3; j++)
        {
            cin>>row[j].ch1>>row[j].ch2>>row[j].sign;
            len = strlen(row[j].ch1);
            if(row[j].sign[0] == 'e')
            {
                for(k = 0; k < len; k++)
                {
                    book[row[j].ch1[k]] = 10;
                    book[row[j].ch2[k]] = 10;
                }
            }
            else if(row[j].sign[0] == 'd')//右重
            {
                for(k = 0; k < len; k++)
                {
                    if(book[row[j].ch1[k]] != 10)
                        --book[row[j].ch1[k]];
                    if(book[row[j].ch2[k]] != 10)
                        ++book[row[j].ch2[k]];   
                }
            }       
            else if(row[j].sign[0] == 'u')//左重
            {
                for(k = 0; k < len; k++)
                {   if(book[row[j].ch1[k]] != 10)
                        ++book[row[j].ch1[k]];
                    if(book[row[j].ch2[k]] != 10)
                        --book[row[j].ch2[k]];   
                }
            }      
        }
        p = max = 0;        
		for(j = 65;j < 77; j++)
		{
			if(book[j] != 10 && abs(book[j]) > max)
			{
				max = abs(book[j]);
				p = j;
			}
		}
        if (book[p] > 0)		printf("%c is the counterfeit coin and it is heavy.\n", p);
		else					printf("%c is the counterfeit coin and it is light.\n", p);
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值