UVA - 424 Integer Inquiry (高精度计算)

One of the first users of BIT’s new supercomputer was Chip Diller. He extended his exploration of
powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers.
“This supercomputer is great,” remarked Chip. “I only wish Timothy were here to see these results.”
(Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky
apartments on Third Street.)
Input
The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger.
Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no
VeryLongInteger will be negative).
The final input line will contain a single zero on a line by itself.
Output
Your program should output the sum of the VeryLongIntegers given in the input.
Sample Input
123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0
Sample Output
370370367037037036703703703670
问题链接https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&page=show_problem&problem=365
问题简述:输入n行数字,遇到单独的一行0之后停止程序,输出他们的和。
问题分析:高精度计算基础题。想法是用string输入,再把每次输入的数字加入到结果。
但是有很多特殊情况处理(比如00+0,000065110等等),要处理前置0与输入00的情况等,于是WA了很久
AC通过的C++语言程序如下:

#include<iostream>
#include <cstring>
#include<string>
using namespace std;
int res[105] = { 0 };
void plus1(int x[], int y[])
{
	int k = x[0] > y[0] ? x[0] : y[0];
	for (int i = 1; i <= k; i++)
	{
		x[i + 1] = x[i + 1] + (x[i] + y[i]) / 10;
		x[i] = (x[i] + y[i]) % 10;
	}
	if (x[k + 1] > 0) { x[0] = k + 1; }
	else x[0] = k;
}
int main()
{
	int n[105] = { 0 };
	string a;
	int zx = 0;
	while (cin >> a)
	{
		if (a == "0") { break; }
		n[0] = a.length();
		for (int i = 1; i <= n[0]; i++) 
		{
			n[i] = a[n[0] - i] - '0';
		}
		int count = n[0];
		while (n[count] == 0)
		{
			n[0]--;
			n[count] = NULL;
			count--;
		}
		if (n[0] == 0)zx++;
		plus1(res, n);
		memset(n, 0, sizeof(n));
	}
	if (zx > 0 && res[0] == 0) { cout << "0"; }
	else
	{
		int v = res[0];
		for (int i = v; i > 0; i--)
		{
			cout << res[i];
		}
	}
	cout << endl;
	return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值