都说天上不会掉馅饼,但有一天gameboy正走在回家的小径上,忽然天上掉下大把大把的馅饼。说来gameboy的人品实在是太好了,这馅饼别处都不掉,就掉落在他身旁的10米范围内。馅饼如果掉在了地上当然就不能吃了,所以gameboy马上卸下身上的背包去接。但由于小径两侧都不能站人,所以他只能在小径上接。由于gameboy平时老呆在房间里玩游戏,虽然在游戏中是个身手敏捷的高手,但在现实中运动神经特别迟钝,每秒种只有在移动不超过一米的范围内接住坠落的馅饼。现在给这条小径如图标上坐标:
为了使问题简化,假设在接下来的一段时间里,馅饼都掉落在0-10这11个位置。开始时gameboy站在5这个位置,因此在第一秒,他只能接到4,5,6这三个位置中其中一个位置上的馅饼。问gameboy最多可能接到多少个馅饼?(假设他的背包可以容纳无穷多个馅饼)
Input
输入数据有多组。每组数据的第一行为以正整数n(0<n<100000),表示有n个馅饼掉在这条小径上。在结下来的n行中,每行有两个整数x,T(0<T<100000),表示在第T秒有一个馅饼掉在x点上。同一秒钟在同一点上可能掉下多个馅饼。n=0时输入结束。
Output
每一组输入数据对应一行输出。输出一个整数m,表示gameboy最多可能接到m个馅饼。
提示:本题的输入数据量比较大,建议用scanf读入,用cin可能会超时。
Sample Input
6
5 1
4 1
6 1
7 2
7 2
8 3
0
Sample Output
4
问题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1176
问题分析:
建立一个DP[a][b]表示在a秒,b坐标时可以得到的馅饼数量
5(t=0)时可能到达的位置
4 5 6 (t=1)时…
3 4 5 6 7
2 3 4 5 6 7 8 …
1 2 3 4 5 6 7 8 9 (t=5)时
0 1 2 3 4 5 6 7 8 9 10 …
从下往上开始DP
状态转移方程:DP[i][j]+=max(DP[i+1][j-1],DP[i+1][j]),DP[i+1][j+1])(表示向左,向右以及不移动)
(当j=10时是由j=9与j=10时决定的,j=0时是由j=0以及j=1决定。)
AC通过的C++语言程序如下:
#include <iostream>
#include <algorithm>
#include <iostream>
#include <string>
#include <stdio.h>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cstdio>
#include <math.h>
#include <climits>
#include <iomanip>
#include <queue>
#include<vector>
using namespace std;
const int N=100005;
int DP[N][15];
int n;
int main()
{
ios::sync_with_stdio(false);
while(cin>>n)
{
if(n==0) break;
memset(DP,0,sizeof(DP));
int f=0;
while(n--)
{
int a,b;
cin>>a>>b;
DP[b][a]++;
if(b>f)
f=b;
}
for(int i=f-1;i>=0;i--)
{
DP[i][0]+=max(max(DP[i+1][0],DP[i+1][1]),0);
for(int j=1;j<10;j++)
{
DP[i][j]+=max(max(DP[i+1][j-1],DP[i+1][j]),DP[i+1][j+1]);
}
DP[i][10]+=max(max(DP[i+1][9],DP[i+1][10]),0);
}
cout<<DP[0][5]<<endl;
}
return 0;
}