HDUOJ 2768 Cat vs. Dog(二分图)

Cat vs. Dog
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2997 Accepted Submission(s): 1176

Problem Description
The latest reality show has hit the TV: ``Cat vs. Dog’’. In this show, a bunch of cats and dogs compete for the very prestigious Best Pet Ever title. In each episode, the cats and dogs get to show themselves off, after which the viewers vote on which pets should stay and which should be forced to leave the show.

Each viewer gets to cast a vote on two things: one pet which should be kept on the show, and one pet which should be thrown out. Also, based on the universal fact that everyone is either a cat lover (i.e. a dog hater) or a dog lover (i.e. a cat hater), it has been decided that each vote must name exactly one cat and exactly one dog.

Ingenious as they are, the producers have decided to use an advancement procedure which guarantees that as many viewers as possible will continue watching the show: the pets that get to stay will be chosen so as to maximize the number of viewers who get both their opinions satisfied. Write a program to calculate this maximum number of viewers.

Input
On the first line one positive number: the number of testcases, at most 100. After that per testcase:

  • One line with three integers c, d, v (1 ≤ c, d ≤ 100 and 0 ≤ v ≤ 500): the number of cats, dogs, and voters.
  • v lines with two pet identifiers each. The first is the pet that this voter wants to keep, the second is the pet that this voter wants to throw out. A pet identifier starts with one of the characters C' orD’, indicating whether the pet is a cat or dog, respectively. The remaining part of the identifier is an integer giving the number of the pet (between 1 and c for cats, and between 1 and d for dogs). So for instance, ``D42’’ indicates dog number 42.

Output
Per testcase:

  • One line with the maximum possible number of satisfied voters for the show.

Sample Input
2
1 1 2
C1 D1
D1 C1
1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output
1
3

Source
NWERC 2008

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2768
solution:把这个完全矛盾的两人连起来、总数减去最大匹配数即答案

#include <bits/stdc++.h>
using namespace std;

bool vis[501];
int match[501];
vector<int> g[501];
string a[501], b[501];

bool dfs(int u)
{
	for (int i = 0; i < g[u].size(); ++i){
		int v = g[u][i];
		if (vis[v])continue;
		vis[v] = true;
		if (match[v] == -1 || dfs(match[v])){
			match[v] = u;
			return true;
		}
	}
	return false;
}

int main()
{
	int t, i, j, c, d, n;
	scanf("%d", &t);
	while (t--){
		for (int i = 0; i <= 500; ++i)g[i].clear();
		scanf("%d%d%d", &c, &d, &n);
		for (int i = 1; i <= n; ++i)cin >> a[i] >> b[i];
		//有两个人完全矛盾的话就连起来
		for (int i = 1; i <= n; ++i){
			for (int j = 1; j <= n; ++j){
				if (a[i] == b[j] || a[j] == b[i])g[i].push_back(j);
			}
		}
		memset(match, -1, sizeof match);
		int ans = 0;
		for (int i = 1; i <= n; ++i){
			memset (vis, 0, sizeof(vis));
			if (dfs(i)) ++ans;
		}
		printf("%d\n", n - ans / 2);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值